aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-05-05 14:10:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-05-05 14:10:54 +0800
commit2d248c1338eec3b8c3e736e9171464eecfd73b7d (patch)
tree295fe6b0aa3d1a914816160f3ad693a541c0e40f /net
parent9807ea2240d409b7485cbac7b9f8cc053711f515 (diff)
downloadfreebsd-ports-gnome-2d248c1338eec3b8c3e736e9171464eecfd73b7d.tar.gz
freebsd-ports-gnome-2d248c1338eec3b8c3e736e9171464eecfd73b7d.tar.zst
freebsd-ports-gnome-2d248c1338eec3b8c3e736e9171464eecfd73b7d.zip
- Add p5-Net-OpenSSH-Parallel 0.12
Net::OpenSSH::Parallel is an scheduler that can run commands in parallel in a set of hosts through SSH. It tries to find a compromise between being simple to use, efficient and covering a good part of the problem space of parallel process execution via SSH. Obviously, it is build on top of Net::OpenSSH! Common usage of the module is as follows: - Create a Net::OpenSSH::Parallel object. - Register the hosts where you want to run commands with the "add_host" method. - Queue the actions you want to run (commands, file copy operations, etc.) using the "push" method. - Call the "run" method and let the parallel scheduler take care of everything! WWW: http://search.cpan.org/dist/Net-OpenSSH-Parallel/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-OpenSSH-Parallel/Makefile28
-rw-r--r--net/p5-Net-OpenSSH-Parallel/distinfo2
-rw-r--r--net/p5-Net-OpenSSH-Parallel/pkg-descr15
-rw-r--r--net/p5-Net-OpenSSH-Parallel/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index becaae325300..af2536b2bd87 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -611,6 +611,7 @@
SUBDIR += p5-Net-OAuth2
SUBDIR += p5-Net-OpenID-Consumer
SUBDIR += p5-Net-OpenSSH
+ SUBDIR += p5-Net-OpenSSH-Parallel
SUBDIR += p5-Net-Packet
SUBDIR += p5-Net-Packet-Target
SUBDIR += p5-Net-ParseWhois
diff --git a/net/p5-Net-OpenSSH-Parallel/Makefile b/net/p5-Net-OpenSSH-Parallel/Makefile
new file mode 100644
index 000000000000..f1e2c17d12b8
--- /dev/null
+++ b/net/p5-Net-OpenSSH-Parallel/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-OpenSSH-Parallel
+# Date created: 2012-05-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenSSH-Parallel
+PORTVERSION= 0.12
+CATEGORIES= net security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Run SSH jobs in parallel
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Net-OpenSSH>=0.39:${PORTSDIR}/net/p5-Net-OpenSSH
+RUN_DEPENDS= p5-Net-OpenSSH>=0.39:${PORTSDIR}/net/p5-Net-OpenSSH
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenSSH::Parallel.3 \
+ Net::OpenSSH::Parallel::Constants.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OpenSSH-Parallel/distinfo b/net/p5-Net-OpenSSH-Parallel/distinfo
new file mode 100644
index 000000000000..e58b257c40ee
--- /dev/null
+++ b/net/p5-Net-OpenSSH-Parallel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-OpenSSH-Parallel-0.12.tar.gz) = 653f8070f2adb1b0b34a1f7d4c6faa7e644e69bc41f760ca80927630a7260ed9
+SIZE (Net-OpenSSH-Parallel-0.12.tar.gz) = 17374
diff --git a/net/p5-Net-OpenSSH-Parallel/pkg-descr b/net/p5-Net-OpenSSH-Parallel/pkg-descr
new file mode 100644
index 000000000000..8f694ac5c974
--- /dev/null
+++ b/net/p5-Net-OpenSSH-Parallel/pkg-descr
@@ -0,0 +1,15 @@
+Net::OpenSSH::Parallel is an scheduler that can run commands in parallel in a
+set of hosts through SSH. It tries to find a compromise between being simple to
+use, efficient and covering a good part of the problem space of parallel process
+execution via SSH.
+
+Obviously, it is build on top of Net::OpenSSH!
+
+Common usage of the module is as follows:
+- Create a Net::OpenSSH::Parallel object.
+- Register the hosts where you want to run commands with the "add_host" method.
+- Queue the actions you want to run (commands, file copy operations, etc.) using
+ the "push" method.
+- Call the "run" method and let the parallel scheduler take care of everything!
+
+WWW: http://search.cpan.org/dist/Net-OpenSSH-Parallel/
diff --git a/net/p5-Net-OpenSSH-Parallel/pkg-plist b/net/p5-Net-OpenSSH-Parallel/pkg-plist
new file mode 100644
index 000000000000..8c3d8209fc46
--- /dev/null
+++ b/net/p5-Net-OpenSSH-Parallel/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/OpenSSH/Parallel.pm
+%%SITE_PERL%%/Net/OpenSSH/Parallel/Constants.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenSSH/Parallel/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenSSH/Parallel
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenSSH
+@dirrmtry %%SITE_PERL%%/Net/OpenSSH/Parallel
+@dirrmtry %%SITE_PERL%%/Net/OpenSSH