aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-12-02 16:49:49 +0800
committerobrien <obrien@FreeBSD.org>2000-12-02 16:49:49 +0800
commit46e1c4f448d6600ada8a20686eafccd63fe7a96e (patch)
tree17bba65d1ab98861061d7dc63736d50eca39109d /net
parent18b4ee5c05b91d4dc403cfde4d178866fb6405b4 (diff)
downloadfreebsd-ports-gnome-46e1c4f448d6600ada8a20686eafccd63fe7a96e.tar.gz
freebsd-ports-gnome-46e1c4f448d6600ada8a20686eafccd63fe7a96e.tar.zst
freebsd-ports-gnome-46e1c4f448d6600ada8a20686eafccd63fe7a96e.zip
Allow the selection of the [sys]log facility to use.
Submitted by: David W. Chapman Jr. <dwcjr@inethouston.net>
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp3-server/Makefile19
-rw-r--r--net/isc-dhcp3-server/files/patch-site.h5
-rw-r--r--net/isc-dhcp3/Makefile19
-rw-r--r--net/isc-dhcp3/files/patch-site.h5
-rw-r--r--net/isc-dhcp30-server/Makefile19
-rw-r--r--net/isc-dhcp30-server/files/patch-site.h5
-rw-r--r--net/isc-dhcp31-server/Makefile19
-rw-r--r--net/isc-dhcp31-server/files/patch-site.h5
-rw-r--r--net/isc-dhcp40-server/Makefile19
-rw-r--r--net/isc-dhcp40-server/files/patch-site.h5
10 files changed, 120 insertions, 0 deletions
diff --git a/net/isc-dhcp3-server/Makefile b/net/isc-dhcp3-server/Makefile
index b8c8642bfd58..36a19536a905 100644
--- a/net/isc-dhcp3-server/Makefile
+++ b/net/isc-dhcp3-server/Makefile
@@ -14,6 +14,12 @@ DISTNAME= dhcp-3.0b2pl${PORTVERSION:S/3.0.b2.//g}
MAINTAINER= obrien@FreeBSD.org
+.if defined(USE_FACILITY)
+_USE_FACILITY:= `${ECHO} ${USE_FACILITY} | ${TR} "[:lower:]" "[:upper:]"`
+USE_FACILITY= ${_USE_FACILITY}
+.else
+USE_FACILITY= DAEMON
+.endif
Y2K= http://www.isc.org/y2k.html
HAS_CONFIGURE= yes
@@ -24,8 +30,21 @@ MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
dhcpd.leases.5
MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
+pre-fetch:
+.if ${USE_FACILITY} == "DAEMON"
+ @${ECHO} ""
+ @${ECHO} " You can choose which syslog faciliy by setting LOG_FACILITY to:"
+ @${ECHO} " daemon, local{0-7}"
+ @${ECHO} " 'daemon' is the default option if one is not defined."
+ @${ECHO} " Press Control-C and run make clean build LOG_FACILITY=<local{0-7}>,"
+ @${ECHO} " if you wish to use a different logging facility."
+ @${ECHO} ""
+ @sleep 2
+.endif
+
post-patch:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/includes/dhcpd.h
+ @${PERL} -pi.fbsd -e "s.!!USE_FACILITY!!.${USE_FACILITY}.g" ${WRKSRC}/includes/site.h
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/client/scripts/freebsd
.for MF in relay/Makefile.dist server/Makefile.dist client/Makefile.dist common/Makefile.dist dhcpctl/Makefile.dist minires/Makefile.dist omapip/Makefile.dist
@${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|DEBUG ?=|g ; s|^CFLAGS[ ]*=|CFLAGS +=|g' ${WRKSRC}/${MF}
diff --git a/net/isc-dhcp3-server/files/patch-site.h b/net/isc-dhcp3-server/files/patch-site.h
new file mode 100644
index 000000000000..6d2d9547f69c
--- /dev/null
+++ b/net/isc-dhcp3-server/files/patch-site.h
@@ -0,0 +1,5 @@
+--- includes/site.h.orig Thu Sep 28 11:24:17 2000
++++ includes/site.h.fbsd Sat Dec 2 00:46:53 2000
+@@ -159 +159 @@
+-/* #define DHCPD_LOG_FACILITY LOG_DAEMON */
++#define DHCPD_LOG_FACILITY LOG_!!USE_FACILITY!!
diff --git a/net/isc-dhcp3/Makefile b/net/isc-dhcp3/Makefile
index b8c8642bfd58..36a19536a905 100644
--- a/net/isc-dhcp3/Makefile
+++ b/net/isc-dhcp3/Makefile
@@ -14,6 +14,12 @@ DISTNAME= dhcp-3.0b2pl${PORTVERSION:S/3.0.b2.//g}
MAINTAINER= obrien@FreeBSD.org
+.if defined(USE_FACILITY)
+_USE_FACILITY:= `${ECHO} ${USE_FACILITY} | ${TR} "[:lower:]" "[:upper:]"`
+USE_FACILITY= ${_USE_FACILITY}
+.else
+USE_FACILITY= DAEMON
+.endif
Y2K= http://www.isc.org/y2k.html
HAS_CONFIGURE= yes
@@ -24,8 +30,21 @@ MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
dhcpd.leases.5
MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
+pre-fetch:
+.if ${USE_FACILITY} == "DAEMON"
+ @${ECHO} ""
+ @${ECHO} " You can choose which syslog faciliy by setting LOG_FACILITY to:"
+ @${ECHO} " daemon, local{0-7}"
+ @${ECHO} " 'daemon' is the default option if one is not defined."
+ @${ECHO} " Press Control-C and run make clean build LOG_FACILITY=<local{0-7}>,"
+ @${ECHO} " if you wish to use a different logging facility."
+ @${ECHO} ""
+ @sleep 2
+.endif
+
post-patch:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/includes/dhcpd.h
+ @${PERL} -pi.fbsd -e "s.!!USE_FACILITY!!.${USE_FACILITY}.g" ${WRKSRC}/includes/site.h
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/client/scripts/freebsd
.for MF in relay/Makefile.dist server/Makefile.dist client/Makefile.dist common/Makefile.dist dhcpctl/Makefile.dist minires/Makefile.dist omapip/Makefile.dist
@${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|DEBUG ?=|g ; s|^CFLAGS[ ]*=|CFLAGS +=|g' ${WRKSRC}/${MF}
diff --git a/net/isc-dhcp3/files/patch-site.h b/net/isc-dhcp3/files/patch-site.h
new file mode 100644
index 000000000000..6d2d9547f69c
--- /dev/null
+++ b/net/isc-dhcp3/files/patch-site.h
@@ -0,0 +1,5 @@
+--- includes/site.h.orig Thu Sep 28 11:24:17 2000
++++ includes/site.h.fbsd Sat Dec 2 00:46:53 2000
+@@ -159 +159 @@
+-/* #define DHCPD_LOG_FACILITY LOG_DAEMON */
++#define DHCPD_LOG_FACILITY LOG_!!USE_FACILITY!!
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
index b8c8642bfd58..36a19536a905 100644
--- a/net/isc-dhcp30-server/Makefile
+++ b/net/isc-dhcp30-server/Makefile
@@ -14,6 +14,12 @@ DISTNAME= dhcp-3.0b2pl${PORTVERSION:S/3.0.b2.//g}
MAINTAINER= obrien@FreeBSD.org
+.if defined(USE_FACILITY)
+_USE_FACILITY:= `${ECHO} ${USE_FACILITY} | ${TR} "[:lower:]" "[:upper:]"`
+USE_FACILITY= ${_USE_FACILITY}
+.else
+USE_FACILITY= DAEMON
+.endif
Y2K= http://www.isc.org/y2k.html
HAS_CONFIGURE= yes
@@ -24,8 +30,21 @@ MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
dhcpd.leases.5
MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
+pre-fetch:
+.if ${USE_FACILITY} == "DAEMON"
+ @${ECHO} ""
+ @${ECHO} " You can choose which syslog faciliy by setting LOG_FACILITY to:"
+ @${ECHO} " daemon, local{0-7}"
+ @${ECHO} " 'daemon' is the default option if one is not defined."
+ @${ECHO} " Press Control-C and run make clean build LOG_FACILITY=<local{0-7}>,"
+ @${ECHO} " if you wish to use a different logging facility."
+ @${ECHO} ""
+ @sleep 2
+.endif
+
post-patch:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/includes/dhcpd.h
+ @${PERL} -pi.fbsd -e "s.!!USE_FACILITY!!.${USE_FACILITY}.g" ${WRKSRC}/includes/site.h
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/client/scripts/freebsd
.for MF in relay/Makefile.dist server/Makefile.dist client/Makefile.dist common/Makefile.dist dhcpctl/Makefile.dist minires/Makefile.dist omapip/Makefile.dist
@${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|DEBUG ?=|g ; s|^CFLAGS[ ]*=|CFLAGS +=|g' ${WRKSRC}/${MF}
diff --git a/net/isc-dhcp30-server/files/patch-site.h b/net/isc-dhcp30-server/files/patch-site.h
new file mode 100644
index 000000000000..6d2d9547f69c
--- /dev/null
+++ b/net/isc-dhcp30-server/files/patch-site.h
@@ -0,0 +1,5 @@
+--- includes/site.h.orig Thu Sep 28 11:24:17 2000
++++ includes/site.h.fbsd Sat Dec 2 00:46:53 2000
+@@ -159 +159 @@
+-/* #define DHCPD_LOG_FACILITY LOG_DAEMON */
++#define DHCPD_LOG_FACILITY LOG_!!USE_FACILITY!!
diff --git a/net/isc-dhcp31-server/Makefile b/net/isc-dhcp31-server/Makefile
index b8c8642bfd58..36a19536a905 100644
--- a/net/isc-dhcp31-server/Makefile
+++ b/net/isc-dhcp31-server/Makefile
@@ -14,6 +14,12 @@ DISTNAME= dhcp-3.0b2pl${PORTVERSION:S/3.0.b2.//g}
MAINTAINER= obrien@FreeBSD.org
+.if defined(USE_FACILITY)
+_USE_FACILITY:= `${ECHO} ${USE_FACILITY} | ${TR} "[:lower:]" "[:upper:]"`
+USE_FACILITY= ${_USE_FACILITY}
+.else
+USE_FACILITY= DAEMON
+.endif
Y2K= http://www.isc.org/y2k.html
HAS_CONFIGURE= yes
@@ -24,8 +30,21 @@ MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
dhcpd.leases.5
MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
+pre-fetch:
+.if ${USE_FACILITY} == "DAEMON"
+ @${ECHO} ""
+ @${ECHO} " You can choose which syslog faciliy by setting LOG_FACILITY to:"
+ @${ECHO} " daemon, local{0-7}"
+ @${ECHO} " 'daemon' is the default option if one is not defined."
+ @${ECHO} " Press Control-C and run make clean build LOG_FACILITY=<local{0-7}>,"
+ @${ECHO} " if you wish to use a different logging facility."
+ @${ECHO} ""
+ @sleep 2
+.endif
+
post-patch:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/includes/dhcpd.h
+ @${PERL} -pi.fbsd -e "s.!!USE_FACILITY!!.${USE_FACILITY}.g" ${WRKSRC}/includes/site.h
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/client/scripts/freebsd
.for MF in relay/Makefile.dist server/Makefile.dist client/Makefile.dist common/Makefile.dist dhcpctl/Makefile.dist minires/Makefile.dist omapip/Makefile.dist
@${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|DEBUG ?=|g ; s|^CFLAGS[ ]*=|CFLAGS +=|g' ${WRKSRC}/${MF}
diff --git a/net/isc-dhcp31-server/files/patch-site.h b/net/isc-dhcp31-server/files/patch-site.h
new file mode 100644
index 000000000000..6d2d9547f69c
--- /dev/null
+++ b/net/isc-dhcp31-server/files/patch-site.h
@@ -0,0 +1,5 @@
+--- includes/site.h.orig Thu Sep 28 11:24:17 2000
++++ includes/site.h.fbsd Sat Dec 2 00:46:53 2000
+@@ -159 +159 @@
+-/* #define DHCPD_LOG_FACILITY LOG_DAEMON */
++#define DHCPD_LOG_FACILITY LOG_!!USE_FACILITY!!
diff --git a/net/isc-dhcp40-server/Makefile b/net/isc-dhcp40-server/Makefile
index b8c8642bfd58..36a19536a905 100644
--- a/net/isc-dhcp40-server/Makefile
+++ b/net/isc-dhcp40-server/Makefile
@@ -14,6 +14,12 @@ DISTNAME= dhcp-3.0b2pl${PORTVERSION:S/3.0.b2.//g}
MAINTAINER= obrien@FreeBSD.org
+.if defined(USE_FACILITY)
+_USE_FACILITY:= `${ECHO} ${USE_FACILITY} | ${TR} "[:lower:]" "[:upper:]"`
+USE_FACILITY= ${_USE_FACILITY}
+.else
+USE_FACILITY= DAEMON
+.endif
Y2K= http://www.isc.org/y2k.html
HAS_CONFIGURE= yes
@@ -24,8 +30,21 @@ MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
dhcpd.leases.5
MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
+pre-fetch:
+.if ${USE_FACILITY} == "DAEMON"
+ @${ECHO} ""
+ @${ECHO} " You can choose which syslog faciliy by setting LOG_FACILITY to:"
+ @${ECHO} " daemon, local{0-7}"
+ @${ECHO} " 'daemon' is the default option if one is not defined."
+ @${ECHO} " Press Control-C and run make clean build LOG_FACILITY=<local{0-7}>,"
+ @${ECHO} " if you wish to use a different logging facility."
+ @${ECHO} ""
+ @sleep 2
+.endif
+
post-patch:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/includes/dhcpd.h
+ @${PERL} -pi.fbsd -e "s.!!USE_FACILITY!!.${USE_FACILITY}.g" ${WRKSRC}/includes/site.h
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/client/scripts/freebsd
.for MF in relay/Makefile.dist server/Makefile.dist client/Makefile.dist common/Makefile.dist dhcpctl/Makefile.dist minires/Makefile.dist omapip/Makefile.dist
@${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|DEBUG ?=|g ; s|^CFLAGS[ ]*=|CFLAGS +=|g' ${WRKSRC}/${MF}
diff --git a/net/isc-dhcp40-server/files/patch-site.h b/net/isc-dhcp40-server/files/patch-site.h
new file mode 100644
index 000000000000..6d2d9547f69c
--- /dev/null
+++ b/net/isc-dhcp40-server/files/patch-site.h
@@ -0,0 +1,5 @@
+--- includes/site.h.orig Thu Sep 28 11:24:17 2000
++++ includes/site.h.fbsd Sat Dec 2 00:46:53 2000
+@@ -159 +159 @@
+-/* #define DHCPD_LOG_FACILITY LOG_DAEMON */
++#define DHCPD_LOG_FACILITY LOG_!!USE_FACILITY!!