aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2001-08-02 23:02:31 +0800
committernbm <nbm@FreeBSD.org>2001-08-02 23:02:31 +0800
commit5afd62afbf2e429624949c74c415efce64fbff16 (patch)
tree6b14628c096ac183e8484f6595494604b8c4c59c /net
parentbd52ece9b9fb825d07a3eddc2fd5b34a35dcde6a (diff)
downloadfreebsd-ports-gnome-5afd62afbf2e429624949c74c415efce64fbff16.tar.gz
freebsd-ports-gnome-5afd62afbf2e429624949c74c415efce64fbff16.tar.zst
freebsd-ports-gnome-5afd62afbf2e429624949c74c415efce64fbff16.zip
Add arprelease 1.0, a Libnet tool to flush arp cache entries from
devices (eg. routers)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/arprelease/Makefile29
-rw-r--r--net/arprelease/distinfo1
-rw-r--r--net/arprelease/pkg-comment1
-rw-r--r--net/arprelease/pkg-descr3
-rw-r--r--net/arprelease/pkg-plist1
6 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index df4f465a9300..e6260557db0a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -16,6 +16,7 @@
SUBDIR += argus
SUBDIR += arla
SUBDIR += arping
+ SUBDIR += arprelease
SUBDIR += arpwatch
SUBDIR += arts++
SUBDIR += ascend-radius
diff --git a/net/arprelease/Makefile b/net/arprelease/Makefile
new file mode 100644
index 000000000000..53a8d2be6303
--- /dev/null
+++ b/net/arprelease/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: arprelease
+# Date created: 02 Aug 2001
+# Whom: nbm
+#
+# $FreeBSD$
+#
+
+PORTNAME= arprelease
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= arprelease
+
+MAINTAINER= nbm@FreeBSD.org
+
+BUILD_DEPENDS= libnet-config:${PORTSDIR}/net/libnet
+
+LIBNET_CONFIG= libnet-config
+
+do-build:
+ (cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -o arprelease arprelease.c \
+ `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --libs`)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/arprelease ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/arprelease/distinfo b/net/arprelease/distinfo
new file mode 100644
index 000000000000..3f9f392216b3
--- /dev/null
+++ b/net/arprelease/distinfo
@@ -0,0 +1 @@
+MD5 (arprelease-1.0.tar.gz) = e9156537a8deb2a481333f7f7c31707f
diff --git a/net/arprelease/pkg-comment b/net/arprelease/pkg-comment
new file mode 100644
index 000000000000..c699b4db3812
--- /dev/null
+++ b/net/arprelease/pkg-comment
@@ -0,0 +1 @@
+Libnet tool to flush arp cache entries from devices (eg. routers)
diff --git a/net/arprelease/pkg-descr b/net/arprelease/pkg-descr
new file mode 100644
index 000000000000..9925d1b399d3
--- /dev/null
+++ b/net/arprelease/pkg-descr
@@ -0,0 +1,3 @@
+This program sends out a custom ARP REQUEST packet with the hardware and
+protocol address information of the sending host to flush the arp cache
+for a given IP on Cisco routers.
diff --git a/net/arprelease/pkg-plist b/net/arprelease/pkg-plist
new file mode 100644
index 000000000000..662ecb7565e9
--- /dev/null
+++ b/net/arprelease/pkg-plist
@@ -0,0 +1 @@
+bin/arprelease