aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-02-28 06:53:10 +0800
committerthierry <thierry@FreeBSD.org>2005-02-28 06:53:10 +0800
commit5baa0a664566a1621b42b6c271463ea9bcb5f75e (patch)
tree65c57b844a35d59e511c8c5ba3d2473ad1beac58 /net
parentcbe39e9ea6afdb98b48feb0a050bc82941ba4f0a (diff)
downloadfreebsd-ports-gnome-5baa0a664566a1621b42b6c271463ea9bcb5f75e.tar.gz
freebsd-ports-gnome-5baa0a664566a1621b42b6c271463ea9bcb5f75e.tar.zst
freebsd-ports-gnome-5baa0a664566a1621b42b6c271463ea9bcb5f75e.zip
Add pear-Net_Ping 2.4, PEAR class to execute ping.
PR: 78040 Submitted by: Antônio Carlos Venâncio Júnior
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Net_Ping/Makefile26
-rw-r--r--net/pear-Net_Ping/distinfo2
-rw-r--r--net/pear-Net_Ping/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 69aa559eac21..585c831baf2e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -552,6 +552,7 @@
SUBDIR += pear-Net_IPv6
SUBDIR += pear-Net_NNTP
SUBDIR += pear-Net_POP3
+ SUBDIR += pear-Net_Ping
SUBDIR += pear-Net_SMTP
SUBDIR += pear-Net_Server
SUBDIR += pear-Net_Sieve
diff --git a/net/pear-Net_Ping/Makefile b/net/pear-Net_Ping/Makefile
new file mode 100644
index 000000000000..416f656e85d0
--- /dev/null
+++ b/net/pear-Net_Ping/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Net_Ping
+# Date created: 24 February 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Ping
+PORTVERSION= 2.4
+CATEGORIES= net pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to execute ping
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net
+FILES= Ping.php
+TESTS= test_result_parsers.php
+EXAMPLES= example.php
+_EXAMPLESDIR= docs/examples
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Ping/distinfo b/net/pear-Net_Ping/distinfo
new file mode 100644
index 000000000000..cc8d26022433
--- /dev/null
+++ b/net/pear-Net_Ping/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_Ping-2.4.tgz) = 0c6aecc5f3139e49b2c49ecd2e222c37
+SIZE (PEAR/Net_Ping-2.4.tgz) = 8408
diff --git a/net/pear-Net_Ping/pkg-descr b/net/pear-Net_Ping/pkg-descr
new file mode 100644
index 000000000000..48cb3de85bd5
--- /dev/null
+++ b/net/pear-Net_Ping/pkg-descr
@@ -0,0 +1,3 @@
+OS independent wrapper class for executing ping calls.
+
+WWW: http://pear.php.net/package/Net_Ping/