aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-06-15 15:19:56 +0800
committersem <sem@FreeBSD.org>2005-06-15 15:19:56 +0800
commit914c8aa0fe4b0dfa6d2f8bca4168eb43390289a5 (patch)
tree8e89ce41278abd0c8374cc687436153aed650aa1 /net
parentd733194abb589f28528b619109a56fcb401f58dc (diff)
downloadfreebsd-ports-gnome-914c8aa0fe4b0dfa6d2f8bca4168eb43390289a5.tar.gz
freebsd-ports-gnome-914c8aa0fe4b0dfa6d2f8bca4168eb43390289a5.tar.zst
freebsd-ports-gnome-914c8aa0fe4b0dfa6d2f8bca4168eb43390289a5.zip
- added support for draft-ietf-dhc-leasequery-08.txt
DHCPLEASEQUERY support. Thanks to Dmitry V. Sukhodoev <raven@chics.ru> for providing this patch - introduced new OPTION to enable DHCPLEASEQUERY support PR: ports/79599 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp3-server/Makefile23
-rw-r--r--net/isc-dhcp3-server/distinfo2
-rw-r--r--net/isc-dhcp30-server/Makefile23
-rw-r--r--net/isc-dhcp30-server/distinfo2
-rw-r--r--net/isc-dhcp31-server/Makefile23
-rw-r--r--net/isc-dhcp31-server/distinfo2
-rw-r--r--net/isc-dhcp40-server/Makefile23
-rw-r--r--net/isc-dhcp40-server/distinfo2
8 files changed, 88 insertions, 12 deletions
diff --git a/net/isc-dhcp3-server/Makefile b/net/isc-dhcp3-server/Makefile
index e52857933d4b..c536c48ed1ab 100644
--- a/net/isc-dhcp3-server/Makefile
+++ b/net/isc-dhcp3-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dhcp
PORTVERSION= 3.0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= dhcp dhcp/dhcp-3.0-history
@@ -34,7 +34,8 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
DHCP_LDAP "add experimental LDAP backend support" off \
DHCP_LDAP_SSL "support LDAP connection over SSL/TLS" on \
OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
- OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off
+ OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off \
+ DHCP_LQ "DHCPLEASEQUERY support used by Cisco uBR's" off
.endif
.include <bsd.port.pre.mk>
@@ -56,6 +57,13 @@ USE_OPENSSL= yes
.endif
.endif
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+# Based on patch from Dmitry Sukhodoev :
+PATCH_SITES= http://bingo.ru/~raven/FreeBSD/patches/ \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
+PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch
+.endif
+
# Global variables
#
@@ -200,7 +208,7 @@ extract-script:
post-patch: patch-scripts patch-makefile-conf \
patch-makefiles-dist patch-man-pages \
patch-pkgmessage patch-site-conf \
- patch-rc-scripts
+ patch-rc-scripts patch-dlq
patch-scripts:
@${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@@ -260,6 +268,15 @@ patch-pkgmessage:
.endif
.endif
+patch-dlq:
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+.if defined(WITH_DHCP_LDAP)
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq-ldap
+.else
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq
+.endif
+.endif
+
# Post-install
#
diff --git a/net/isc-dhcp3-server/distinfo b/net/isc-dhcp3-server/distinfo
index 20e307a041b5..ff1a69160ea2 100644
--- a/net/isc-dhcp3-server/distinfo
+++ b/net/isc-dhcp3-server/distinfo
@@ -2,3 +2,5 @@ MD5 (dhcp-3.0.2.tar.gz) = 04800a111521e7442749b2ce883f962b
SIZE (dhcp-3.0.2.tar.gz) = 853313
MD5 (dhcp-3.0.2-ldap-patch) = 08908b2f06b5e985d78d7c28797c5a37
SIZE (dhcp-3.0.2-ldap-patch) = 229453
+MD5 (dhcp-3.0.2-dlq-patch) = 0e071945cc986d7ecdfd9b41fc4a102b
+SIZE (dhcp-3.0.2-dlq-patch) = 7655
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
index e52857933d4b..c536c48ed1ab 100644
--- a/net/isc-dhcp30-server/Makefile
+++ b/net/isc-dhcp30-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dhcp
PORTVERSION= 3.0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= dhcp dhcp/dhcp-3.0-history
@@ -34,7 +34,8 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
DHCP_LDAP "add experimental LDAP backend support" off \
DHCP_LDAP_SSL "support LDAP connection over SSL/TLS" on \
OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
- OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off
+ OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off \
+ DHCP_LQ "DHCPLEASEQUERY support used by Cisco uBR's" off
.endif
.include <bsd.port.pre.mk>
@@ -56,6 +57,13 @@ USE_OPENSSL= yes
.endif
.endif
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+# Based on patch from Dmitry Sukhodoev :
+PATCH_SITES= http://bingo.ru/~raven/FreeBSD/patches/ \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
+PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch
+.endif
+
# Global variables
#
@@ -200,7 +208,7 @@ extract-script:
post-patch: patch-scripts patch-makefile-conf \
patch-makefiles-dist patch-man-pages \
patch-pkgmessage patch-site-conf \
- patch-rc-scripts
+ patch-rc-scripts patch-dlq
patch-scripts:
@${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@@ -260,6 +268,15 @@ patch-pkgmessage:
.endif
.endif
+patch-dlq:
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+.if defined(WITH_DHCP_LDAP)
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq-ldap
+.else
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq
+.endif
+.endif
+
# Post-install
#
diff --git a/net/isc-dhcp30-server/distinfo b/net/isc-dhcp30-server/distinfo
index 20e307a041b5..ff1a69160ea2 100644
--- a/net/isc-dhcp30-server/distinfo
+++ b/net/isc-dhcp30-server/distinfo
@@ -2,3 +2,5 @@ MD5 (dhcp-3.0.2.tar.gz) = 04800a111521e7442749b2ce883f962b
SIZE (dhcp-3.0.2.tar.gz) = 853313
MD5 (dhcp-3.0.2-ldap-patch) = 08908b2f06b5e985d78d7c28797c5a37
SIZE (dhcp-3.0.2-ldap-patch) = 229453
+MD5 (dhcp-3.0.2-dlq-patch) = 0e071945cc986d7ecdfd9b41fc4a102b
+SIZE (dhcp-3.0.2-dlq-patch) = 7655
diff --git a/net/isc-dhcp31-server/Makefile b/net/isc-dhcp31-server/Makefile
index e52857933d4b..c536c48ed1ab 100644
--- a/net/isc-dhcp31-server/Makefile
+++ b/net/isc-dhcp31-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dhcp
PORTVERSION= 3.0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= dhcp dhcp/dhcp-3.0-history
@@ -34,7 +34,8 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
DHCP_LDAP "add experimental LDAP backend support" off \
DHCP_LDAP_SSL "support LDAP connection over SSL/TLS" on \
OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
- OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off
+ OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off \
+ DHCP_LQ "DHCPLEASEQUERY support used by Cisco uBR's" off
.endif
.include <bsd.port.pre.mk>
@@ -56,6 +57,13 @@ USE_OPENSSL= yes
.endif
.endif
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+# Based on patch from Dmitry Sukhodoev :
+PATCH_SITES= http://bingo.ru/~raven/FreeBSD/patches/ \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
+PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch
+.endif
+
# Global variables
#
@@ -200,7 +208,7 @@ extract-script:
post-patch: patch-scripts patch-makefile-conf \
patch-makefiles-dist patch-man-pages \
patch-pkgmessage patch-site-conf \
- patch-rc-scripts
+ patch-rc-scripts patch-dlq
patch-scripts:
@${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@@ -260,6 +268,15 @@ patch-pkgmessage:
.endif
.endif
+patch-dlq:
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+.if defined(WITH_DHCP_LDAP)
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq-ldap
+.else
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq
+.endif
+.endif
+
# Post-install
#
diff --git a/net/isc-dhcp31-server/distinfo b/net/isc-dhcp31-server/distinfo
index 20e307a041b5..ff1a69160ea2 100644
--- a/net/isc-dhcp31-server/distinfo
+++ b/net/isc-dhcp31-server/distinfo
@@ -2,3 +2,5 @@ MD5 (dhcp-3.0.2.tar.gz) = 04800a111521e7442749b2ce883f962b
SIZE (dhcp-3.0.2.tar.gz) = 853313
MD5 (dhcp-3.0.2-ldap-patch) = 08908b2f06b5e985d78d7c28797c5a37
SIZE (dhcp-3.0.2-ldap-patch) = 229453
+MD5 (dhcp-3.0.2-dlq-patch) = 0e071945cc986d7ecdfd9b41fc4a102b
+SIZE (dhcp-3.0.2-dlq-patch) = 7655
diff --git a/net/isc-dhcp40-server/Makefile b/net/isc-dhcp40-server/Makefile
index e52857933d4b..c536c48ed1ab 100644
--- a/net/isc-dhcp40-server/Makefile
+++ b/net/isc-dhcp40-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dhcp
PORTVERSION= 3.0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= dhcp dhcp/dhcp-3.0-history
@@ -34,7 +34,8 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
DHCP_LDAP "add experimental LDAP backend support" off \
DHCP_LDAP_SSL "support LDAP connection over SSL/TLS" on \
OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
- OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off
+ OPENSSL_PORT "use OpenSSL from ports (required by TLS)" off \
+ DHCP_LQ "DHCPLEASEQUERY support used by Cisco uBR's" off
.endif
.include <bsd.port.pre.mk>
@@ -56,6 +57,13 @@ USE_OPENSSL= yes
.endif
.endif
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+# Based on patch from Dmitry Sukhodoev :
+PATCH_SITES= http://bingo.ru/~raven/FreeBSD/patches/ \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
+PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch
+.endif
+
# Global variables
#
@@ -200,7 +208,7 @@ extract-script:
post-patch: patch-scripts patch-makefile-conf \
patch-makefiles-dist patch-man-pages \
patch-pkgmessage patch-site-conf \
- patch-rc-scripts
+ patch-rc-scripts patch-dlq
patch-scripts:
@${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@@ -260,6 +268,15 @@ patch-pkgmessage:
.endif
.endif
+patch-dlq:
+.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
+.if defined(WITH_DHCP_LDAP)
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq-ldap
+.else
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-dlq
+.endif
+.endif
+
# Post-install
#
diff --git a/net/isc-dhcp40-server/distinfo b/net/isc-dhcp40-server/distinfo
index 20e307a041b5..ff1a69160ea2 100644
--- a/net/isc-dhcp40-server/distinfo
+++ b/net/isc-dhcp40-server/distinfo
@@ -2,3 +2,5 @@ MD5 (dhcp-3.0.2.tar.gz) = 04800a111521e7442749b2ce883f962b
SIZE (dhcp-3.0.2.tar.gz) = 853313
MD5 (dhcp-3.0.2-ldap-patch) = 08908b2f06b5e985d78d7c28797c5a37
SIZE (dhcp-3.0.2-ldap-patch) = 229453
+MD5 (dhcp-3.0.2-dlq-patch) = 0e071945cc986d7ecdfd9b41fc4a102b
+SIZE (dhcp-3.0.2-dlq-patch) = 7655