aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-04-15 16:45:06 +0800
committerkrion <krion@FreeBSD.org>2004-04-15 16:45:06 +0800
commit9485ac89b6f3fbd8c97f54b59b6b9a9a9af3e52c (patch)
tree48dc7227795bcb51a305b3771396af1b140a9b25 /net
parent42b0c1136b6f38c3717258afd1cfcaa54b0d8f6a (diff)
downloadfreebsd-ports-gnome-9485ac89b6f3fbd8c97f54b59b6b9a9a9af3e52c.tar.gz
freebsd-ports-gnome-9485ac89b6f3fbd8c97f54b59b6b9a9a9af3e52c.tar.zst
freebsd-ports-gnome-9485ac89b6f3fbd8c97f54b59b6b9a9a9af3e52c.zip
- Fix build on 4-x
- Respect PTHREAD_CFLAGS[LIBS] Reported by: bento via kris
Diffstat (limited to 'net')
-rw-r--r--net/howl/Makefile5
-rw-r--r--net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c11
2 files changed, 16 insertions, 0 deletions
diff --git a/net/howl/Makefile b/net/howl/Makefile
index 16324fef90e6..c392cb6a10b9 100644
--- a/net/howl/Makefile
+++ b/net/howl/Makefile
@@ -18,9 +18,14 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+USE_REINPLACE= yes
MAN8= mDNSResponder.8
PLIST_SUB= VERSION="${PORTVERSION}"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread||g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c b/net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c
new file mode 100644
index 000000000000..3f4ed9ba8c59
--- /dev/null
+++ b/net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c
@@ -0,0 +1,11 @@
+--- src/lib/howl/NotOSX/notosx_mdns.c.orig Thu Apr 15 10:34:27 2004
++++ src/lib/howl/NotOSX/notosx_mdns.c Thu Apr 15 10:34:38 2004
+@@ -54,7 +54,7 @@
+ #include <salt/assert.h>
+ #include <salt/log.h>
+ #include <stdio.h>
+-
++#include <sys/time.h>
+
+ #define CACHE_SIZE 750
+