aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /net
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'net')
-rw-r--r--net/cagibi/Makefile4
-rw-r--r--net/kdenetwork4-filesharing/Makefile4
-rw-r--r--net/kdenetwork4-strigi-analyzers/Makefile4
-rw-r--r--net/kdenetwork4/Makefile17
-rw-r--r--net/kget/Makefile4
-rw-r--r--net/kio-upnp-ms/Makefile4
-rw-r--r--net/knemo-kde4/Makefile4
-rw-r--r--net/krdc/Makefile4
-rw-r--r--net/krfb/Makefile4
-rw-r--r--net/kwooty/Makefile4
-rw-r--r--net/libkfbapi/Makefile4
-rw-r--r--net/libkvkontakte/Makefile4
-rw-r--r--net/libproxy-kde/Makefile3
-rw-r--r--net/smb4k-kde4/Makefile4
-rw-r--r--net/zeroconf-ioslave/Makefile4
15 files changed, 36 insertions, 36 deletions
diff --git a/net/cagibi/Makefile b/net/cagibi/Makefile
index 91eee010c017..d2182129473f 100644
--- a/net/cagibi/Makefile
+++ b/net/cagibi/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= KDE/stable/${PORTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE SSDP/uPNP proxy
-USES= cmake tar:bzip2
-USE_KDE4= automoc4
+USES= cmake kde:4 tar:bzip2
+USE_KDE= automoc4
USE_QT4= corelib network xml dbus \
qmake_build moc_build rcc_build uic_build
diff --git a/net/kdenetwork4-filesharing/Makefile b/net/kdenetwork4-filesharing/Makefile
index d4cae5925bb6..a57d84be74e0 100644
--- a/net/kdenetwork4-filesharing/Makefile
+++ b/net/kdenetwork4-filesharing/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Filesharing via Samba
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/net/kdenetwork4-strigi-analyzers/Makefile b/net/kdenetwork4-strigi-analyzers/Makefile
index 4b8d88d0cbbe..620971ad349a 100644
--- a/net/kdenetwork4-strigi-analyzers/Makefile
+++ b/net/kdenetwork4-strigi-analyzers/Makefile
@@ -11,8 +11,8 @@ COMMENT= Strigi analyzers for network-related file formats
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USE_KDE4= kdelibs strigi automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs strigi automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 910abb634b63..83d07859bc6a 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -7,31 +7,30 @@ CATEGORIES= net kde
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Network applications (meta port)
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= FILESHARING KDNSSD KGET KOPETE KRDC KRFB STRIGI
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
FILESHARING_DESC= Network file sharing via Samba
-FILESHARING_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/sambausershareplugin.so:net/kdenetwork4-filesharing
+FILESHARING_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/sambausershareplugin.so:net/kdenetwork4-filesharing
KDNSSD_DESC= Network monitor for DNS-SD services (Zeroconf)
-KDNSSD_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kded_dnssdwatcher.so:net/zeroconf-ioslave
+KDNSSD_RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/kded_dnssdwatcher.so:net/zeroconf-ioslave
KGET_DESC= Download manager
-KGET_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kget:net/kget
+KGET_RUN_DEPENDS= ${KDE_PREFIX}/bin/kget:net/kget
KOPETE_DESC= Multi-protocol instant messenger
-KOPETE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kopete:net-im/kopete-kde4
+KOPETE_RUN_DEPENDS= ${KDE_PREFIX}/bin/kopete:net-im/kopete-kde4
KRDC_DESC= RDP and VNC client
-KRDC_RUN_DEPENDS= ${KDE4_PREFIX}/bin/krdc:net/krdc
+KRDC_RUN_DEPENDS= ${KDE_PREFIX}/bin/krdc:net/krdc
KRFB_DESC= Desktop Sharing (VNC server)
-KRFB_RUN_DEPENDS= ${KDE4_PREFIX}/bin/krfb:net/krfb
+KRFB_RUN_DEPENDS= ${KDE_PREFIX}/bin/krfb:net/krfb
STRIGI_DESC= Strigi analyzers for network-related file formats
-STRIGI_RUN_DEPENDS= ${KDE4_PREFIX}/lib/strigi/strigita_torrent_analyzer.so:net/kdenetwork4-strigi-analyzers
+STRIGI_RUN_DEPENDS= ${KDE_PREFIX}/lib/strigi/strigita_torrent_analyzer.so:net/kdenetwork4-strigi-analyzers
.include <bsd.port.mk>
diff --git a/net/kget/Makefile b/net/kget/Makefile
index bcffb58327a6..5a06cabc7abd 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -16,10 +16,10 @@ LIB_DEPENDS= libgpgme.so:security/gpgme \
libqca.so:devel/qca \
libboost_thread.so:devel/boost-libs
-USE_KDE4= kdelibs workspace libkonq \
+USES= cmake:outsource kde:4 shebangfix sqlite tar:xz
+USE_KDE= kdelibs workspace libkonq \
nepomuk-core nepomuk-widgets automoc4 ontologies \
soprano
-USES= cmake:outsource shebangfix sqlite tar:xz
SHEBANG_FILES= conf/*.pl
USE_QT4= gui sql moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/net/kio-upnp-ms/Makefile b/net/kio-upnp-ms/Makefile
index e2f2680aee5c..74ef8b7e8c85 100644
--- a/net/kio-upnp-ms/Makefile
+++ b/net/kio-upnp-ms/Makefile
@@ -13,8 +13,8 @@ COMMENT= KIO slave to access UPnP MediaServers
LIB_DEPENDS= libHUpnp.so:net/hupnp
-USES= cmake tar:bzip2
-USE_KDE4= automoc4 kdelibs
+USES= cmake kde:4 tar:bzip2
+USE_KDE= automoc4 kdelibs
USE_QT4= corelib network xml dbus gui \
qmake_build moc_build rcc_build uic_build
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 4e61d2d27fce..fa2478e1bd7a 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -9,10 +9,10 @@ DISTNAME= 12956-${PORTNAME}-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= KDE network monitor
-USES= cmake gettext shebangfix tar:xz
+USES= cmake gettext kde:4 shebangfix tar:xz
SHEBANG_FILES= src/kconf_update/*.pl
USE_QT4= qmake_build moc_build uic_build rcc_build
-USE_KDE4= kdelibs workspace automoc4
+USE_KDE= kdelibs workspace automoc4
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/net/krdc/Makefile b/net/krdc/Makefile
index 35947463fa44..6f7e85aa9bda 100644
--- a/net/krdc/Makefile
+++ b/net/krdc/Makefile
@@ -13,8 +13,8 @@ COMMENT= RDP and VNC client for KDE
LIB_DEPENDS= libvncserver.so:net/libvncserver \
libtelepathy-qt4.so:net-im/telepathy-qt4
-USES= cmake:outsource tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/net/krfb/Makefile b/net/krfb/Makefile
index 54f0579d3707..8eaee33e6919 100644
--- a/net/krfb/Makefile
+++ b/net/krfb/Makefile
@@ -11,8 +11,8 @@ COMMENT= VNC server for KDE
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4
-USES= alias cmake:outsource jpeg tar:xz
-USE_KDE4= kdelibs automoc4
+USES= alias cmake:outsource jpeg kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= corelib gui network \
moc_build qmake_build rcc_build uic_build
diff --git a/net/kwooty/Makefile b/net/kwooty/Makefile
index ed91658cdae4..b46537fc507b 100644
--- a/net/kwooty/Makefile
+++ b/net/kwooty/Makefile
@@ -14,9 +14,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/unrar:archivers/unrar \
${LOCALBASE}/bin/par2:archivers/par2cmdline \
${LOCALBASE}/bin/7z:archivers/p7zip
-USE_KDE4= kdelibs automoc4 workspace
+USES= cmake gettext kde:4
+USE_KDE= kdelibs automoc4 workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-USES= cmake gettext
USE_LDCONFIG= yes
post-patch:
diff --git a/net/libkfbapi/Makefile b/net/libkfbapi/Makefile
index 8572b0ceb65f..cd8651563636 100644
--- a/net/libkfbapi/Makefile
+++ b/net/libkfbapi/Makefile
@@ -14,8 +14,8 @@ LICENSE= LGPL20
LIB_DEPENDS= libqjson.so:devel/qjson
-USES= cmake:outsource gettext tar:bzip2
-USE_KDE4= automoc4 kdelibs pimlibs
+USES= cmake:outsource gettext kde:4 tar:bzip2
+USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
USE_QT4= gui webkit \
qmake_build moc_build rcc_build uic_build
diff --git a/net/libkvkontakte/Makefile b/net/libkvkontakte/Makefile
index 6905fdcfd384..24d9cf91c927 100644
--- a/net/libkvkontakte/Makefile
+++ b/net/libkvkontakte/Makefile
@@ -14,9 +14,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LIB
LIB_DEPENDS= libqjson.so:devel/qjson
-USES= cmake:outsource gettext pkgconfig tar:xz
+USES= cmake:outsource gettext kde:4 pkgconfig tar:xz
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_KDE4= automoc4 kdelibs
+USE_KDE= automoc4 kdelibs
USE_LDCONFIG= yes
PLIST_SUB+= SHLIB_VER="${PORTVERSION}"
diff --git a/net/libproxy-kde/Makefile b/net/libproxy-kde/Makefile
index 2f3ff462ae3b..33d1ed888b06 100644
--- a/net/libproxy-kde/Makefile
+++ b/net/libproxy-kde/Makefile
@@ -16,7 +16,8 @@ DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
ALL_TARGET= config_kde
-USE_KDE4= runtime
+USE_KDE= runtime
+USES+= kde:4
LIBPROXY_SLAVE= kde
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index 8ae46fe00d28..b482f54998a8 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -16,9 +16,9 @@ RUN_DEPENDS= sudo:security/sudo \
SAMBA_PORT?= net/samba36
-USES= cmake gettext tar:bzip2
+USES= cmake gettext kde:4 tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/kde4
-USE_KDE4= kdelibs automoc4 runtime
+USE_KDE= kdelibs automoc4 runtime
USE_QT4= corelib gui network opengl script svg webkit \
qmake_build moc_build rcc_build uic_build phonon
DOCSDIR= ${PREFIX}/share/doc/HTML/en/smb4k
diff --git a/net/zeroconf-ioslave/Makefile b/net/zeroconf-ioslave/Makefile
index f64d0f2c18ce..770beb791a1b 100644
--- a/net/zeroconf-ioslave/Makefile
+++ b/net/zeroconf-ioslave/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Network monitor for DNS-SD services (Zeroconf)
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>