aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-01 04:25:24 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-01 04:25:24 +0800
commitaf345e25931c8a2c1c374aad66ed05dc96334193 (patch)
tree0aa8acce6c0dbac42bfbab384a8db8c56ee9c726 /net
parent3ee359ba3231273cbe606c89f489476604a2ea14 (diff)
downloadfreebsd-ports-gnome-af345e25931c8a2c1c374aad66ed05dc96334193.tar.gz
freebsd-ports-gnome-af345e25931c8a2c1c374aad66ed05dc96334193.tar.zst
freebsd-ports-gnome-af345e25931c8a2c1c374aad66ed05dc96334193.zip
add py-rrdtool 0.1
Python C extension module to access RRDtool files
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-rrdtool/Makefile26
-rw-r--r--net/py-rrdtool/distinfo1
-rw-r--r--net/py-rrdtool/pkg-comment1
-rw-r--r--net/py-rrdtool/pkg-descr3
-rw-r--r--net/py-rrdtool/pkg-plist1
6 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6b077c926841..0dff77f8c4db 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -405,6 +405,7 @@
SUBDIR += py-libnet
SUBDIR += py-medusa
SUBDIR += py-pcap
+ SUBDIR += py-rrdtool
SUBDIR += py-smb
SUBDIR += py-snmp
SUBDIR += py-soap
diff --git a/net/py-rrdtool/Makefile b/net/py-rrdtool/Makefile
new file mode 100644
index 000000000000..de133e2f6a41
--- /dev/null
+++ b/net/py-rrdtool/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: py-rrdtool
+# Date created: May 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rrdtool
+PORTVERSION= 0.1
+CATEGORIES= net python
+MASTER_SITES= http://download.extreme-ware.com/open-projects/PyRRDtool/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyRRDtool-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= rrd:${PORTSDIR}/net/rrdtool
+
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/PyRRDtool/src
+
+do-configure:
+ @(cd ${WRKSRC} ; ${MAKE} -f Makefile.pre.in boot)
+
+.include <bsd.port.mk>
diff --git a/net/py-rrdtool/distinfo b/net/py-rrdtool/distinfo
new file mode 100644
index 000000000000..5c90db135cac
--- /dev/null
+++ b/net/py-rrdtool/distinfo
@@ -0,0 +1 @@
+MD5 (PyRRDtool-0.1.tar.gz) = 2b5a5b8d67302ffe7eb60ec925787470
diff --git a/net/py-rrdtool/pkg-comment b/net/py-rrdtool/pkg-comment
new file mode 100644
index 000000000000..67c8ee3bbc8c
--- /dev/null
+++ b/net/py-rrdtool/pkg-comment
@@ -0,0 +1 @@
+Python C extension module to access RRDtool files
diff --git a/net/py-rrdtool/pkg-descr b/net/py-rrdtool/pkg-descr
new file mode 100644
index 000000000000..394f35699c98
--- /dev/null
+++ b/net/py-rrdtool/pkg-descr
@@ -0,0 +1,3 @@
+Python C extension module to access RRDtool files
+
+WWW: http://download.extreme-ware.com/
diff --git a/net/py-rrdtool/pkg-plist b/net/py-rrdtool/pkg-plist
new file mode 100644
index 000000000000..339ff0313691
--- /dev/null
+++ b/net/py-rrdtool/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/RRDtoolmodule.so