aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-01-20 16:11:26 +0800
committergahr <gahr@FreeBSD.org>2014-01-20 16:11:26 +0800
commitd281d787f1489e467580cd286aba3cb877b2713a (patch)
tree676131f5b8b068eb4c6dff696af812c84a112b84 /net
parent36ff06237cd3fd53cab3bb5e82d168fa6df55046 (diff)
downloadfreebsd-ports-gnome-d281d787f1489e467580cd286aba3cb877b2713a.tar.gz
freebsd-ports-gnome-d281d787f1489e467580cd286aba3cb877b2713a.tar.zst
freebsd-ports-gnome-d281d787f1489e467580cd286aba3cb877b2713a.zip
- Fix build with modern compilers [MFH]
- Convert to USES=tk - STAGE-clean MFH: 2014Q1 PR: 185840 Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/ns/Makefile14
-rw-r--r--net/ns/files/patch-common_tclAppInit.cc10
-rw-r--r--net/ns/files/patch-common_tkAppInit.c10
-rw-r--r--net/ns/files/patch-mdart_mdart_adp.cc20
-rw-r--r--net/ns/files/patch-nix_nixnode.cc11
-rw-r--r--net/ns/pkg-plist249
6 files changed, 181 insertions, 133 deletions
diff --git a/net/ns/Makefile b/net/ns/Makefile
index 5d187b5ea185..9d6c3ec295fc 100644
--- a/net/ns/Makefile
+++ b/net/ns/Makefile
@@ -12,8 +12,7 @@ COMMENT= Discrete event simulator for networking research
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
-USES= gmake
-USE_TK= 85+
+USES= gmake tk:85+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} \
--with-tk-ver=${TK_VER} \
@@ -22,11 +21,8 @@ CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} \
WRKSRC= ${WRKDIR}/ns-${PORTVERSION}
-MAN1= ns.1
-
OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -42,11 +38,11 @@ post-patch:
${WRKSRC}/indep-utils/webtrace-conv/ucb/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/ns.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/ns ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ns.1 ${STAGEDIR}${PREFIX}/man/man1
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/tcl/ex/*.tcl ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tcl/ex/*.tcl ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/net/ns/files/patch-common_tclAppInit.cc b/net/ns/files/patch-common_tclAppInit.cc
new file mode 100644
index 000000000000..bae1e555d458
--- /dev/null
+++ b/net/ns/files/patch-common_tclAppInit.cc
@@ -0,0 +1,10 @@
+--- common/tclAppInit.cc.orig 2014-01-17 10:38:38.000000000 +0100
++++ common/tclAppInit.cc 2014-01-17 10:38:45.000000000 +0100
+@@ -237,7 +237,6 @@
+ Tcl_AppInit(Tcl_Interp *interp)
+ {
+ #ifdef MEMDEBUG_SIMULATIONS
+- extern MemTrace *globalMemTrace;
+ globalMemTrace = new MemTrace;
+ #endif
+
diff --git a/net/ns/files/patch-common_tkAppInit.c b/net/ns/files/patch-common_tkAppInit.c
new file mode 100644
index 000000000000..5511d0aa47f2
--- /dev/null
+++ b/net/ns/files/patch-common_tkAppInit.c
@@ -0,0 +1,10 @@
+--- common/tkAppInit.cc.orig 2014-01-17 10:37:16.000000000 +0100
++++ common/tkAppInit.cc 2014-01-17 10:38:11.000000000 +0100
+@@ -293,7 +293,6 @@
+ Tcl_AppInit(Tcl_Interp *interp)
+ {
+ #ifdef MEMDEBUG_SIMULATIONS
+- extern MemTrace *globalMemTrace;
+ globalMemTrace = new MemTrace;
+ #endif
+
diff --git a/net/ns/files/patch-mdart_mdart_adp.cc b/net/ns/files/patch-mdart_mdart_adp.cc
new file mode 100644
index 000000000000..c1ba494f279b
--- /dev/null
+++ b/net/ns/files/patch-mdart_mdart_adp.cc
@@ -0,0 +1,20 @@
+--- mdart/mdart_adp.cc.orig 2014-01-17 10:40:08.000000000 +0100
++++ mdart/mdart_adp.cc 2014-01-17 10:40:17.000000000 +0100
+@@ -105,7 +105,7 @@
+ #ifdef DEBUG_ADP
+ fprintf(stdout, "%.9f\tADP::sendDarq(%d)\t\t\tin node %d\twith address %s\n", CURRENT_TIME, reqId, mdart_->id_, bitString(mdart_->address_));
+ #endif
+- nsaddr_t dstAdd_ = hash(reqId);
++ nsaddr_t dstAdd_ = ::hash(reqId);
+ #ifdef DEBUG_ADP
+ fprintf(stdout, "\tsending darq for node %s\n", bitString(dstAdd_));
+ #endif
+@@ -393,7 +393,7 @@
+ fprintf(stdout, "%.9f\tMDART::sendDaup()\t\t\t\tin node %d\twith address %s\n", CURRENT_TIME, mdart_->id_, bitString(mdart_->address_));
+ // printDHT();
+ #endif
+- nsaddr_t dstAdd_ = hash(mdart_->id_);
++ nsaddr_t dstAdd_ = ::hash(mdart_->id_);
+ #ifdef DEBUG_ADP
+ fprintf(stdout, "\tsending daup for node %s\n", bitString(dstAdd_));
+ mdart_->routingTable_->print();
diff --git a/net/ns/files/patch-nix_nixnode.cc b/net/ns/files/patch-nix_nixnode.cc
new file mode 100644
index 000000000000..abad38525e6b
--- /dev/null
+++ b/net/ns/files/patch-nix_nixnode.cc
@@ -0,0 +1,11 @@
+--- nix/nixnode.cc.orig 2014-01-17 10:33:55.000000000 +0100
++++ nix/nixnode.cc 2014-01-17 10:35:51.000000000 +0100
+@@ -156,8 +156,6 @@
+ if (last.first == NODE_NONE)
+ {
+ prev = m_Adj.begin();
+- if (prev == (EdgeVec_it) NULL) // ! How can this happen?
+- return(NodeWeight_t(NODE_NONE, 0));
+ pE = *prev;
+ if(0)printf("NextAdj returning first edge %ld\n",
+ pE->m_n);
diff --git a/net/ns/pkg-plist b/net/ns/pkg-plist
index cdf2d0ac16cc..6d735ca52abe 100644
--- a/net/ns/pkg-plist
+++ b/net/ns/pkg-plist
@@ -1,125 +1,126 @@
bin/ns
-%%EXAMPLESDIR%%/agent-gen-script.tcl
-%%EXAMPLESDIR%%/agent-gen.tcl
-%%EXAMPLESDIR%%/aomdv.tcl
-%%EXAMPLESDIR%%/callback_demo.tcl
-%%EXAMPLESDIR%%/dccp.tcl
-%%EXAMPLESDIR%%/diffusion-prob-run.tcl
-%%EXAMPLESDIR%%/diffusion-rate-run.tcl
-%%EXAMPLESDIR%%/dumbbell.tcl
-%%EXAMPLESDIR%%/example.tcl
-%%EXAMPLESDIR%%/flooding-run.tcl
-%%EXAMPLESDIR%%/flooding.tcl
-%%EXAMPLESDIR%%/fq-cbr.tcl
-%%EXAMPLESDIR%%/fq.tcl
-%%EXAMPLESDIR%%/grid2.tcl
-%%EXAMPLESDIR%%/gridkeeper.tcl
-%%EXAMPLESDIR%%/hier-rtg-10.tcl
-%%EXAMPLESDIR%%/hier-rtg-100.tcl
-%%EXAMPLESDIR%%/hts100-0.tcl
-%%EXAMPLESDIR%%/lantest.tcl
-%%EXAMPLESDIR%%/large-scale-web-traffic-old.tcl
-%%EXAMPLESDIR%%/large-scale-web-traffic.tcl
-%%EXAMPLESDIR%%/large-sim.tcl
-%%EXAMPLESDIR%%/mac-test.tcl
-%%EXAMPLESDIR%%/many_tcp.tcl
-%%EXAMPLESDIR%%/manytcp_trmodel.tcl
-%%EXAMPLESDIR%%/mcast.tcl
-%%EXAMPLESDIR%%/miptest.tcl
-%%EXAMPLESDIR%%/nam-example-em.tcl
-%%EXAMPLESDIR%%/nam-example.tcl
-%%EXAMPLESDIR%%/nam-large-flowid.tcl
-%%EXAMPLESDIR%%/nam-separate-trace.tcl
-%%EXAMPLESDIR%%/nam-simplexlink.tcl
-%%EXAMPLESDIR%%/omni-run.tcl
-%%EXAMPLESDIR%%/pkts.tcl
-%%EXAMPLESDIR%%/puma.tcl
-%%EXAMPLESDIR%%/ranvar.tcl
-%%EXAMPLESDIR%%/rbp_demo.tcl
-%%EXAMPLESDIR%%/rc.tcl
-%%EXAMPLESDIR%%/redlight.tcl
-%%EXAMPLESDIR%%/rng-test.tcl
-%%EXAMPLESDIR%%/rng-test2.tcl
-%%EXAMPLESDIR%%/route-gen.tcl
-%%EXAMPLESDIR%%/sat-aloha.tcl
-%%EXAMPLESDIR%%/sat-iridium-links.tcl
-%%EXAMPLESDIR%%/sat-iridium-nodes.tcl
-%%EXAMPLESDIR%%/sat-iridium.tcl
-%%EXAMPLESDIR%%/sat-mixed.tcl
-%%EXAMPLESDIR%%/sat-repeater.tcl
-%%EXAMPLESDIR%%/sat-teledesic-links.tcl
-%%EXAMPLESDIR%%/sat-teledesic-nodes.tcl
-%%EXAMPLESDIR%%/sat-teledesic.tcl
-%%EXAMPLESDIR%%/sat-wired.tcl
-%%EXAMPLESDIR%%/shuttle-mcast.tcl
-%%EXAMPLESDIR%%/shuttle.tcl
-%%EXAMPLESDIR%%/simple-dyn.tcl
-%%EXAMPLESDIR%%/simple-eqp.tcl
-%%EXAMPLESDIR%%/simple-eqp1.tcl
-%%EXAMPLESDIR%%/simple-fsm-tcp.tcl
-%%EXAMPLESDIR%%/simple-heap.tcl
-%%EXAMPLESDIR%%/simple-plm.tcl
-%%EXAMPLESDIR%%/simple-rtg.tcl
-%%EXAMPLESDIR%%/simple-rtp.tcl
-%%EXAMPLESDIR%%/simple-tcp.tcl
-%%EXAMPLESDIR%%/simple-webcache-comp.tcl
-%%EXAMPLESDIR%%/simple-webcache-trace.tcl
-%%EXAMPLESDIR%%/simple-webcache.tcl
-%%EXAMPLESDIR%%/simple-wireless.tcl
-%%EXAMPLESDIR%%/simple.tcl
-%%EXAMPLESDIR%%/src_test.tcl
-%%EXAMPLESDIR%%/srm-adapt-rep-session.tcl
-%%EXAMPLESDIR%%/srm-adapt-rep.tcl
-%%EXAMPLESDIR%%/srm-adapt-req-session.tcl
-%%EXAMPLESDIR%%/srm-adapt-req.tcl
-%%EXAMPLESDIR%%/srm-chain-session.tcl
-%%EXAMPLESDIR%%/srm-chain.tcl
-%%EXAMPLESDIR%%/srm-demo.tcl
-%%EXAMPLESDIR%%/srm-session.tcl
-%%EXAMPLESDIR%%/srm-star-session.tcl
-%%EXAMPLESDIR%%/srm-star.tcl
-%%EXAMPLESDIR%%/srm.tcl
-%%EXAMPLESDIR%%/ss.tcl
-%%EXAMPLESDIR%%/swp.tcl
-%%EXAMPLESDIR%%/t1000.tcl
-%%EXAMPLESDIR%%/tcp-et.tcl
-%%EXAMPLESDIR%%/tcp-int.tcl
-%%EXAMPLESDIR%%/tcpapp.tcl
-%%EXAMPLESDIR%%/tcpecn.tcl
-%%EXAMPLESDIR%%/tcpsrm.tcl
-%%EXAMPLESDIR%%/test-drr.tcl
-%%EXAMPLESDIR%%/test-emulator.tcl
-%%EXAMPLESDIR%%/test-rcvr.tcl
-%%EXAMPLESDIR%%/test-rlm.tcl
-%%EXAMPLESDIR%%/test-suite-intserv.tcl
-%%EXAMPLESDIR%%/test-suite.tcl
-%%EXAMPLESDIR%%/test-tbf.tcl
-%%EXAMPLESDIR%%/tg.tcl
-%%EXAMPLESDIR%%/topo-gen-script.tcl
-%%EXAMPLESDIR%%/topo-gen.tcl
-%%EXAMPLESDIR%%/topo-view.tcl
-%%EXAMPLESDIR%%/trace-driven.tcl
-%%EXAMPLESDIR%%/udpdata.tcl
-%%EXAMPLESDIR%%/varybell.tcl
-%%EXAMPLESDIR%%/virtual-classifier.tcl
-%%EXAMPLESDIR%%/vlantest-flat.tcl
-%%EXAMPLESDIR%%/vlantest-hier.tcl
-%%EXAMPLESDIR%%/vlantest-mcst.tcl
-%%EXAMPLESDIR%%/web-traffic-embobj.tcl
-%%EXAMPLESDIR%%/web-traffic.tcl
-%%EXAMPLESDIR%%/wired-cum-wireless-sim.tcl
-%%EXAMPLESDIR%%/wireless-demo-csci694.tcl
-%%EXAMPLESDIR%%/wireless-dsdv-newnode.tcl
-%%EXAMPLESDIR%%/wireless-flooding.tcl
-%%EXAMPLESDIR%%/wireless-landmark.tcl
-%%EXAMPLESDIR%%/wireless-mip-test.tcl
-%%EXAMPLESDIR%%/wireless-mitf.tcl
-%%EXAMPLESDIR%%/wireless-newnode-energy.tcl
-%%EXAMPLESDIR%%/wireless-pkt-demo.tcl
-%%EXAMPLESDIR%%/wireless-shadowing-test.tcl
-%%EXAMPLESDIR%%/wireless-shadowing-vis-test.tcl
-%%EXAMPLESDIR%%/wireless-simple-mac.tcl
-%%EXAMPLESDIR%%/wireless-test.tcl
-%%EXAMPLESDIR%%/wireless.tcl
-%%EXAMPLESDIR%%/worm.tcl
-@dirrm %%EXAMPLESDIR%%
+man/man1/ns.1.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/agent-gen-script.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/agent-gen.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/aomdv.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/callback_demo.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dccp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/diffusion-prob-run.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/diffusion-rate-run.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dumbbell.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/flooding-run.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/flooding.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fq-cbr.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fq.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grid2.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gridkeeper.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hier-rtg-10.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hier-rtg-100.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hts100-0.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lantest.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/large-scale-web-traffic-old.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/large-scale-web-traffic.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/large-sim.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mac-test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/many_tcp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manytcp_trmodel.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mcast.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/miptest.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nam-example-em.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nam-example.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nam-large-flowid.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nam-separate-trace.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nam-simplexlink.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/omni-run.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pkts.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/puma.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ranvar.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rbp_demo.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rc.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/redlight.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rng-test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rng-test2.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/route-gen.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-aloha.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-iridium-links.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-iridium-nodes.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-iridium.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-mixed.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-repeater.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-teledesic-links.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-teledesic-nodes.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-teledesic.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sat-wired.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shuttle-mcast.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shuttle.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-dyn.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-eqp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-eqp1.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-fsm-tcp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-heap.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-plm.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-rtg.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-rtp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-tcp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-webcache-comp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-webcache-trace.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-webcache.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-wireless.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src_test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-adapt-rep-session.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-adapt-rep.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-adapt-req-session.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-adapt-req.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-chain-session.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-chain.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-demo.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-session.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-star-session.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm-star.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/srm.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ss.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/swp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/t1000.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp-et.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp-int.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcpapp.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcpecn.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcpsrm.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-drr.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-emulator.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-rcvr.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-rlm.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-suite-intserv.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-suite.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-tbf.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tg.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/topo-gen-script.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/topo-gen.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/topo-view.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trace-driven.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/udpdata.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/varybell.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/virtual-classifier.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vlantest-flat.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vlantest-hier.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vlantest-mcst.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web-traffic-embobj.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web-traffic.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wired-cum-wireless-sim.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-demo-csci694.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-dsdv-newnode.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-flooding.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-landmark.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-mip-test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-mitf.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-newnode-energy.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-pkt-demo.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-shadowing-test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-shadowing-vis-test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-simple-mac.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless-test.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wireless.tcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/worm.tcl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%