aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-14 10:12:51 +0800
committerwill <will@FreeBSD.org>2001-03-14 10:12:51 +0800
commitd9b72f8ebcfe8260520553dd68a784402146b826 (patch)
tree84afd6791d61d898f0379e387f4df6b9f79e044d /net
parent13761122274c2e6b63de671f7b76f533d9b015bb (diff)
downloadfreebsd-ports-gnome-d9b72f8ebcfe8260520553dd68a784402146b826.tar.gz
freebsd-ports-gnome-d9b72f8ebcfe8260520553dd68a784402146b826.tar.zst
freebsd-ports-gnome-d9b72f8ebcfe8260520553dd68a784402146b826.zip
Add dhcping 1.0, a program to send DHCP request to DHCP server
for monitoring purposes. PR: 25480 Submitted by: Edwin Groothuis (edwin@mavetju.org)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/dhcping/Makefile21
-rw-r--r--net/dhcping/distinfo1
-rw-r--r--net/dhcping/pkg-comment1
-rw-r--r--net/dhcping/pkg-descr7
-rw-r--r--net/dhcping/pkg-plist1
6 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5a1eaffb917b..cd0df6744767 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -62,6 +62,7 @@
SUBDIR += dgd
SUBDIR += dgd-lpmud
SUBDIR += dgd-net
+ SUBDIR += dhcping
SUBDIR += dhid
SUBDIR += dhcpconf
SUBDIR += dhisd
diff --git a/net/dhcping/Makefile b/net/dhcping/Makefile
new file mode 100644
index 000000000000..5d4cb7c088c2
--- /dev/null
+++ b/net/dhcping/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: dhcping
+# Date created: 1 March 2001
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhcping
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.mavetju.org/download/
+
+MAINTAINER= edwin@mavetju.org
+
+MAN8= dhcping.8
+
+pre-build:
+ ${PERL} -pi.orig -e "s@gcc@${CC}@g; \
+ s@-Wall -g@-Wall ${CFLAGS}@g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/dhcping/distinfo b/net/dhcping/distinfo
new file mode 100644
index 000000000000..5254c87daeba
--- /dev/null
+++ b/net/dhcping/distinfo
@@ -0,0 +1 @@
+MD5 (dhcping-1.0.tar.gz) = 1544d0cfb1d9d3186a2b0ce50128534c
diff --git a/net/dhcping/pkg-comment b/net/dhcping/pkg-comment
new file mode 100644
index 000000000000..d1ce212d2029
--- /dev/null
+++ b/net/dhcping/pkg-comment
@@ -0,0 +1 @@
+Send DHCP request to DHCP server for monitoring purposes
diff --git a/net/dhcping/pkg-descr b/net/dhcping/pkg-descr
new file mode 100644
index 000000000000..519a89ebe70e
--- /dev/null
+++ b/net/dhcping/pkg-descr
@@ -0,0 +1,7 @@
+This program allows a system administrator to check if a remote
+DHCP server is still functioning.
+
+WWW: http://www.mavetju.org
+
+- Edwin Groothuis
+edwin@mavetju.org
diff --git a/net/dhcping/pkg-plist b/net/dhcping/pkg-plist
new file mode 100644
index 000000000000..fa1d789573ac
--- /dev/null
+++ b/net/dhcping/pkg-plist
@@ -0,0 +1 @@
+bin/dhcping