aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2008-05-08 19:07:30 +0800
committervsevolod <vsevolod@FreeBSD.org>2008-05-08 19:07:30 +0800
commite24d3bba86981d07f1b00d5aa4a1279bbc699423 (patch)
tree1fad09adbe991755f7693c6e858dd6b0a10d2e4e /net
parent4300c14941a2c5cb262184657a09cfa3aa1f0655 (diff)
downloadfreebsd-ports-gnome-e24d3bba86981d07f1b00d5aa4a1279bbc699423.tar.gz
freebsd-ports-gnome-e24d3bba86981d07f1b00d5aa4a1279bbc699423.tar.zst
freebsd-ports-gnome-e24d3bba86981d07f1b00d5aa4a1279bbc699423.zip
Add perl client for beanstalkd, in-memory workqueue daemon.
Submitted by: Anton Yuzhaninov <citrin @ citrin.ru> via private email
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Queue-Beanstalk/Makefile24
-rw-r--r--net/p5-Queue-Beanstalk/distinfo3
-rw-r--r--net/p5-Queue-Beanstalk/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aee6a984bcd3..b860b7b716b4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -590,6 +590,7 @@
SUBDIR += p5-Parallel-MPI
SUBDIR += p5-Parallel-Pvm
SUBDIR += p5-PlRPC
+ SUBDIR += p5-Queue-Beanstalk
SUBDIR += p5-REST-Application
SUBDIR += p5-REST-Google
SUBDIR += p5-RPC-Simple
diff --git a/net/p5-Queue-Beanstalk/Makefile b/net/p5-Queue-Beanstalk/Makefile
new file mode 100644
index 000000000000..a2edca5afad4
--- /dev/null
+++ b/net/p5-Queue-Beanstalk/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Queue-Beanstalk
+# Date created: 2008-05-06
+# Whom: Anton Yuzhaninov <citrin@citrin.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Queue-Beanstalk
+PORTVERSION= 0.02
+CATEGORIES= net
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= citrin@citrin.ru
+COMMENT= Client for beanstalkd, in-memory workqueue daemon
+
+PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
+
+MAN3= Queue::Beanstalk.3
+PLIST_FILES= "%%SITE_PERL%%/Queue/Beanstalk.pm"
+PLIST_FILES+= "@dirrmtry %%SITE_PERL%%/Queue"
+
+.include <bsd.port.mk>
diff --git a/net/p5-Queue-Beanstalk/distinfo b/net/p5-Queue-Beanstalk/distinfo
new file mode 100644
index 000000000000..b540bf2c8bec
--- /dev/null
+++ b/net/p5-Queue-Beanstalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (Queue-Beanstalk-0.02.tar.gz) = b39d70a0e4cb3f3e806bff223dbe79ac
+SHA256 (Queue-Beanstalk-0.02.tar.gz) = 71092037c786f84f414950750d8e7798932968ba0a28c268e724cb5739f492c2
+SIZE (Queue-Beanstalk-0.02.tar.gz) = 6760
diff --git a/net/p5-Queue-Beanstalk/pkg-descr b/net/p5-Queue-Beanstalk/pkg-descr
new file mode 100644
index 000000000000..c5d706bdc20c
--- /dev/null
+++ b/net/p5-Queue-Beanstalk/pkg-descr
@@ -0,0 +1,4 @@
+Queue::Beanstalk is a Perl client for beanstalkd, a fast, distributed,
+in-memory workqueue daemon.
+
+WWW: http://search.cpan.org/dist/Queue-Beanstalk/