aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-04-19 03:12:15 +0800
committerdinoex <dinoex@FreeBSD.org>2012-04-19 03:12:15 +0800
commitf1d8e915c1d9718b62ee0fdf91513a83b3df7294 (patch)
tree6b6b5275c2b8cf6bd41d1a273c1d5bf673f0d2af /net
parent8bb29a06b65c470ed9f8b762f7add3ccb833fb8c (diff)
downloadfreebsd-ports-gnome-f1d8e915c1d9718b62ee0fdf91513a83b3df7294.tar.gz
freebsd-ports-gnome-f1d8e915c1d9718b62ee0fdf91513a83b3df7294.tar.zst
freebsd-ports-gnome-f1d8e915c1d9718b62ee0fdf91513a83b3df7294.zip
- update libnet-devel to 1.1.6
Diffstat (limited to 'net')
-rw-r--r--net/libnet-devel/Makefile12
-rw-r--r--net/libnet-devel/distinfo4
-rw-r--r--net/libnet-devel/files/patch-libnet.h.in12
-rw-r--r--net/libnet-devel/files/patch-libnet_write.c10
-rw-r--r--net/libnet-devel/pkg-plist5
5 files changed, 22 insertions, 21 deletions
diff --git a/net/libnet-devel/Makefile b/net/libnet-devel/Makefile
index 04c639021f2d..6bab86c8f210 100644
--- a/net/libnet-devel/Makefile
+++ b/net/libnet-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libnet
-PORTVERSION= 1.1.5
-PORTREVISION= 1
+PORTVERSION= 1.1.6
CATEGORIES= net
MASTER_SITES= SF/libnet-dev
@@ -21,7 +20,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-link-layer=${LIBNET_LINK}
-SHORT_VER= 115
+SHORT_VER= 116
SHORT_NAME= ${PORTNAME}${SHORT_VER}
DOCSDIR= ${PREFIX}/share/doc/${SHORT_NAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${SHORT_NAME}
@@ -29,9 +28,10 @@ USE_LDCONFIG= ${PREFIX}/lib/${SHORT_NAME}
PLIST_SUB= SVER=${SHORT_VER} SNAME=${SHORT_NAME} VERSION=${PORTVERSION}
MAN3= libnet-functions.h.3 libnet-macros.h.3 libnet.h.3
-DOCS= README doc/BUGS doc/CHANGELOG doc/CONTRIB doc/COPYING \
+DOCS= README doc/CHANGELOG doc/CONTRIB doc/COPYING \
doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING doc/PORTED \
doc/RAWSOCKET_NON_SEQUITUR doc/TODO
+
EXAMPLES= sample/*.c
OPTIONS= NONE "link layer none" off \
@@ -66,8 +66,8 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${PREFIX}/bin/${SHORT_NAME}-config
@cd ${PREFIX}/lib && \
- ${LN} -sf ${SHORT_NAME}/libnet.so libnet-${PORTVERSION}.so.7 && \
- ${LN} -sf libnet-${PORTVERSION}.so.7 libnet-${PORTVERSION}.so
+ ${LN} -sf ${SHORT_NAME}/libnet.so libnet-${PORTVERSION}.so.8 && \
+ ${LN} -sf libnet-${PORTVERSION}.so.8 libnet-${PORTVERSION}.so
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
diff --git a/net/libnet-devel/distinfo b/net/libnet-devel/distinfo
index 3aed36d4693d..a68fdb318450 100644
--- a/net/libnet-devel/distinfo
+++ b/net/libnet-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libnet-1.1.5.tar.gz) = 75588f8d1232e1df34eccf2dba5e66be197b345a07fae80d8275db994496a20d
-SIZE (libnet-1.1.5.tar.gz) = 1190258
+SHA256 (libnet-1.1.6.tar.gz) = d392bb5825c4b6b672fc93a0268433c86dc964e1500c279dc6d0711ea6ec467a
+SIZE (libnet-1.1.6.tar.gz) = 1202970
diff --git a/net/libnet-devel/files/patch-libnet.h.in b/net/libnet-devel/files/patch-libnet.h.in
new file mode 100644
index 000000000000..384bc0ad7941
--- /dev/null
+++ b/net/libnet-devel/files/patch-libnet.h.in
@@ -0,0 +1,12 @@
+--- include/libnet.h.in.orig 2012-03-06 01:45:46.000000000 +0100
++++ include/libnet.h.in 2012-04-18 20:37:06.000000000 +0200
+@@ -81,6 +81,9 @@
+ #if !defined(__WIN32__)
+ # include <sys/socket.h>
+ # include <net/if.h>
++# if (__FreeBSD__)
++# include <netinet/in.h>
++# endif
+ #else /* __WIN32__ */
+ # if (__CYGWIN__)
+ # include <sys/socket.h>
diff --git a/net/libnet-devel/files/patch-libnet_write.c b/net/libnet-devel/files/patch-libnet_write.c
deleted file mode 100644
index 06243cae521d..000000000000
--- a/net/libnet-devel/files/patch-libnet_write.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libnet_write.c.orig 2010-11-03 19:35:12.000000000 +0100
-+++ src/libnet_write.c 2010-11-15 18:24:35.000000000 +0100
-@@ -32,6 +32,7 @@
- *
- */
-
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include <netinet/udp.h>
-
diff --git a/net/libnet-devel/pkg-plist b/net/libnet-devel/pkg-plist
index 227e40c6787d..f6f3c622a014 100644
--- a/net/libnet-devel/pkg-plist
+++ b/net/libnet-devel/pkg-plist
@@ -9,10 +9,9 @@ include/%%SNAME%%/libnet/libnet-types.h
lib/%%SNAME%%/libnet.a
lib/%%SNAME%%/libnet.la
lib/%%SNAME%%/libnet.so
-lib/%%SNAME%%/libnet.so.7
+lib/%%SNAME%%/libnet.so.8
lib/libnet-%%VERSION%%.so
-lib/libnet-%%VERSION%%.so.7
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
+lib/libnet-%%VERSION%%.so.8
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
%%PORTDOCS%%%%DOCSDIR%%/COPYING