aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-05-05 01:44:50 +0800
committerwxs <wxs@FreeBSD.org>2008-05-05 01:44:50 +0800
commitf405b891237246141f80cdabf56956f7eae4d8ba (patch)
treef9821304b698f6c6677d4e99d787378000b0ce98 /net
parent0265dd22b74bcde04f426e072204271bb6d212cf (diff)
downloadfreebsd-ports-gnome-f405b891237246141f80cdabf56956f7eae4d8ba.tar.gz
freebsd-ports-gnome-f405b891237246141f80cdabf56956f7eae4d8ba.tar.zst
freebsd-ports-gnome-f405b891237246141f80cdabf56956f7eae4d8ba.zip
Properly pick up libdbi.
Add support for RRD, off by default. PR: ports/121650 Submitted by: Mel <mel.xyzzy@rachie.is-a-geek.net> Approved by: garga (mentor), maintainer
Diffstat (limited to 'net')
-rw-r--r--net/bmon/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
index cca9c0e9762e..01cb2f4a17e7 100644
--- a/net/bmon/Makefile
+++ b/net/bmon/Makefile
@@ -7,15 +7,17 @@
PORTNAME= bmon
PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://people.suug.ch/~tgr/bmon/files/
MAINTAINER= nistor@snickers.org
COMMENT= Portable bandwidth monitor and rate estimator
-LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
+OPTIONS= RRDTOOL "Enable RRD support" Off \
+ DBI "Enable DBI support" On
+CONFIGURE_ENV+= "LDFLAGS=-L${LOCALBASE}/lib" "CPPFLAGS=-I${LOCALBASE}/include"
GNU_CONFIGURE= YES
USE_GMAKE= YES
MAKEFILE= GNUmakefile
@@ -23,8 +25,18 @@ MAKEFILE= GNUmakefile
MAN1= bmon.1
PLIST_FILES= sbin/bmon
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RRDTOOL)
+BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
+.endif
+
+.if defined(WITH_DBI)
+LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/bmon ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/man/bmon.1 ${PREFIX}/man/man1/bmon.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>