aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2005-08-29 21:53:14 +0800
committervsevolod <vsevolod@FreeBSD.org>2005-08-29 21:53:14 +0800
commitf7eaf9f7f977fee1f2564d5bb0bf01db74b7af19 (patch)
treee493fdd0a4742a2d32ba8feb582cd0ef58136356 /net
parent5c75877c62d6bb4f7062da71181e167a9c2de126 (diff)
downloadfreebsd-ports-gnome-f7eaf9f7f977fee1f2564d5bb0bf01db74b7af19.tar.gz
freebsd-ports-gnome-f7eaf9f7f977fee1f2564d5bb0bf01db74b7af19.tar.zst
freebsd-ports-gnome-f7eaf9f7f977fee1f2564d5bb0bf01db74b7af19.zip
Add py-radix - a python radix tree implementation.
PR: 84779 Submitted by: Lars Erik Gullerud <lerik@nolink.net> Approved by: perky (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-radix/Makefile22
-rw-r--r--net/py-radix/distinfo2
-rw-r--r--net/py-radix/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 089e0181bcf4..4f9e4db6bb5f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -665,6 +665,7 @@
SUBDIR += py-msnp
SUBDIR += py-pcap
SUBDIR += py-pyxmpp
+ SUBDIR += py-radix
SUBDIR += py-rrdpipe
SUBDIR += py-rrdtool_lgpl
SUBDIR += py-rt
diff --git a/net/py-radix/Makefile b/net/py-radix/Makefile
new file mode 100644
index 000000000000..74ea0947cbee
--- /dev/null
+++ b/net/py-radix/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: py-radix
+# Date created: 10. August, 2005
+# Whom: Lars Erik Gullerud <lerik@nolink.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= radix
+PORTVERSION= 0.4
+CATEGORIES= net python
+MASTER_SITES= http://www2.mindrot.org/files/py-radix/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= lerik@nolink.net
+COMMENT= A Python radix-tree implementation
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/radix.so
+
+.include <bsd.port.mk>
diff --git a/net/py-radix/distinfo b/net/py-radix/distinfo
new file mode 100644
index 000000000000..510ea1b0eef7
--- /dev/null
+++ b/net/py-radix/distinfo
@@ -0,0 +1,2 @@
+MD5 (py-radix-0.4.tar.gz) = a3e7a2cb078c009e39633aa4034ad523
+SIZE (py-radix-0.4.tar.gz) = 15712
diff --git a/net/py-radix/pkg-descr b/net/py-radix/pkg-descr
new file mode 100644
index 000000000000..0e47be22d711
--- /dev/null
+++ b/net/py-radix/pkg-descr
@@ -0,0 +1,7 @@
+py-radix is an implementation of a radix tree data structure
+for the storage and retrieval of IPv4 and IPv6 network prefixes.
+The radix tree is the data structure most commonly used for
+routing table lookups. It efficiently stores network prefixes of
+varying lengths and allows fast lookups of containing networks.
+
+WWW: http://www.mindrot.org/py-radix.html