aboutsummaryrefslogtreecommitdiffstats
path: root/news/atp/Makefile
diff options
context:
space:
mode:
authordburr <dburr@FreeBSD.org>1998-06-11 20:27:58 +0800
committerdburr <dburr@FreeBSD.org>1998-06-11 20:27:58 +0800
commit798bdb49f2528e594a279010d2f8dfd1e9776ac4 (patch)
treee36f75df5b3d5ceb3e6044b236d47564c260cf65 /news/atp/Makefile
parentc3a9c4f10400e0005ffb25e55b0a96055d0d2cc1 (diff)
downloadfreebsd-ports-gnome-798bdb49f2528e594a279010d2f8dfd1e9776ac4.tar.gz
freebsd-ports-gnome-798bdb49f2528e594a279010d2f8dfd1e9776ac4.tar.zst
freebsd-ports-gnome-798bdb49f2528e594a279010d2f8dfd1e9776ac4.zip
Mission: Move ports/comms/atp into ports/news/atp.
Phase IV: easy-import atp. MISSION UPDATE FROM I.M.F. HQ: I have been saying "ports/mail/atp" up till now. I just changed my mind -- I'm puttin' this sucker in "ports/news/atp" I base this on what little precedent we have in the ports tree -- our only other port that deals with this is plor, a SOUP/QWK packet reader, and it's in news/. This is really kind of a tough call, though, as neither mail/ nor news/ is really 100% appropriate.
Diffstat (limited to 'news/atp/Makefile')
-rw-r--r--news/atp/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/news/atp/Makefile b/news/atp/Makefile
new file mode 100644
index 000000000000..8c64903c9b13
--- /dev/null
+++ b/news/atp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: atp
+# Version required: 1.50
+# Date created: 9 Nov 1997
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= atp-1.50-src
+PKGNAME= atp-1.50
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= system/bbs/mail
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ unzip:${PORTSDIR}/archivers/unzip
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+
+USE_GMAKE= YES
+GNU_CONFIGURE= YES
+
+MAN1= atp.1 \
+ atpdiag.1 \
+ rot13.1
+MAN3= editline.3
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>