aboutsummaryrefslogtreecommitdiffstats
path: root/news/brag/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-20 05:48:11 +0800
committerpav <pav@FreeBSD.org>2005-07-20 05:48:11 +0800
commitfacb69454ab90650c0e5e88d23a63de7681142ef (patch)
tree50dd028b698f67b8b02cd691dc61d79fa0ec1d95 /news/brag/Makefile
parentebbaaab1284463862d7bee20bc9ec34d00546ba4 (diff)
downloadfreebsd-ports-gnome-facb69454ab90650c0e5e88d23a63de7681142ef.tar.gz
freebsd-ports-gnome-facb69454ab90650c0e5e88d23a63de7681142ef.tar.zst
freebsd-ports-gnome-facb69454ab90650c0e5e88d23a63de7681142ef.zip
Brag collects and assembles multipart binary attachements from newsgroups.
It is a robust command line tool, well suited to run as a cron job. PR: ports/83745 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'news/brag/Makefile')
-rw-r--r--news/brag/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/news/brag/Makefile b/news/brag/Makefile
new file mode 100644
index 000000000000..cf5faea42b5f
--- /dev/null
+++ b/news/brag/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: brag
+# Date created: 19 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= brag
+PORTVERSION= 1.4.1
+CATEGORIES= news tcl84
+MASTER_SITES= http://brag.sourceforge.net/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Download and assemble multipart binaries from newsgroups
+
+RUN_DEPENDS= uudeview:${PORTSDIR}/converters/uudeview \
+ ${TCLSH}:${PORTSDIR}/lang/tcl84
+
+USE_REINPLACE= yes
+
+MAN1= brag.1
+PLIST_FILES= bin/brag
+PORTDOCS= CHANGES README
+
+TCLSH= tclsh8.4
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(exec\ \)tclsh|\1${TCLSH}|' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>