aboutsummaryrefslogtreecommitdiffstats
path: root/news/inn-stable
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-01-08 18:17:50 +0800
committerclement <clement@FreeBSD.org>2004-01-08 18:17:50 +0800
commit1b166ea4c6204fee17220ef1ab8e7e673d7fa39c (patch)
tree3562bb014e4f0dd7dccd1512af2e9bc0b70991f3 /news/inn-stable
parent196c215474efe2ed328abfc2c0babea472f55cdc (diff)
downloadfreebsd-ports-gnome-1b166ea4c6204fee17220ef1ab8e7e673d7fa39c.tar.gz
freebsd-ports-gnome-1b166ea4c6204fee17220ef1ab8e7e673d7fa39c.tar.zst
freebsd-ports-gnome-1b166ea4c6204fee17220ef1ab8e7e673d7fa39c.zip
- Fix potentially exploitable buffer overflow.
http://lists.litech.org/pipermail/inn-workers/2004q1/002763.html Approved by: erwin (mentor) (implicitly)
Diffstat (limited to 'news/inn-stable')
-rw-r--r--news/inn-stable/Makefile3
-rw-r--r--news/inn-stable/files/patch-innd::art.c24
2 files changed, 26 insertions, 1 deletions
diff --git a/news/inn-stable/Makefile b/news/inn-stable/Makefile
index d58cf5fbe0ed..3540415d7dd8 100644
--- a/news/inn-stable/Makefile
+++ b/news/inn-stable/Makefile
@@ -7,13 +7,14 @@
PORTNAME= inn
PORTVERSION= ${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= news ipv6
MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/ \
http://www.cultdeadsheep.org/FreeBSD/ports/download/distfiles/
PKGNAMESUFFIX= -${BRANCH}
DISTNAME= ${PORTNAME}-${BRANCH:U}-${SNAPSHOT}
-MAINTAINER= sheepkiller@cultdeadsheep.org
+MAINTAINER= clement@FreeBSD.org
COMMENT= InterNetNews -- the Internet meets Netnews
BRANCH= stable
diff --git a/news/inn-stable/files/patch-innd::art.c b/news/inn-stable/files/patch-innd::art.c
new file mode 100644
index 000000000000..7943a772f23e
--- /dev/null
+++ b/news/inn-stable/files/patch-innd::art.c
@@ -0,0 +1,24 @@
+--- innd/art.c.orig Sat Jul 12 19:40:34 2003
++++ innd/art.c Thu Jan 8 10:09:34 2004
+@@ -1773,7 +1773,7 @@
+ bool
+ ARTpost(CHANNEL *cp)
+ {
+- char *p, **groups, ControlWord[SMBUF], tmpbuff[32], **hops;
++ char *p, **groups, ControlWord[SMBUF], **hops, *controlgroup;
+ int i, j, *isp, hopcount, oerrno, canpost;
+ NEWSGROUP *ngp, **ngptr;
+ SITE *sp;
+@@ -2184,9 +2184,10 @@
+ * or control. */
+ if (IsControl && Accepted && !ToGroup) {
+ ControlStore = true;
+- FileGlue(tmpbuff, "control", '.', ControlWord);
+- if ((ngp = NGfind(tmpbuff)) == NULL)
++ controlgroup = concat("control.", ControlWord, (char *) 0);
++ if ((ngp = NGfind(controlgroup)) == NULL)
+ ngp = NGfind(ARTctl);
++ free(controlgroup);
+ ngp->PostCount = 0;
+ ngptr = GroupPointers;
+ *ngptr++ = ngp;