aboutsummaryrefslogtreecommitdiffstats
path: root/news/inn
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-08 21:46:50 +0800
committermat <mat@FreeBSD.org>2016-08-08 21:46:50 +0800
commitaccc153f0c7ee632df7b714f1861b98898e90e7c (patch)
tree509f9c56f6c9e206681219518e92866874b3ae54 /news/inn
parentc333a42bbacfd478a1ae703c628fc3f6f2ce3575 (diff)
downloadfreebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.tar.gz
freebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.tar.zst
freebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.zip
USE_BDB cleanup.
- USE_BDB=4x+ -> USES=bdb. - USE_BDB=yes -> USES=bdb. - USE_BDB=xx -> USES=bdb:xx. Other modernisations when I see them. PR: 209183 Sponsored by: Absolight
Diffstat (limited to 'news/inn')
-rw-r--r--news/inn/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index a797102f3195..e7155897d8e4 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -60,7 +60,7 @@ PLIST_SUB+= LIBVER=${LIBVER_LONG:R:R} LIBVER_LONG=${LIBVER_LONG}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBERKELEYDB}
-USE_BDB= 44+
+USES+= bdb
CONFIGURE_ARGS+= --with-bdb=${LOCALBASE} \
--with-bdb-lib=${LOCALBASE}/lib \
--with-bdb-include=${BDB_INCLUDE_DIR}
@@ -108,7 +108,7 @@ PLIST_SUB+= WITHOUT_TAGGED_HASH=""
SUB_LIST+= DBZ_FILES="${DBZ_FILES}"
.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
+USES+= ssl
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif