aboutsummaryrefslogtreecommitdiffstats
path: root/news/knews
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /news/knews
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'news/knews')
-rw-r--r--news/knews/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/news/knews/Makefile b/news/knews/Makefile
index bedc86cef49e..1293ac82cb85 100644
--- a/news/knews/Makefile
+++ b/news/knews/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=dinoex
MAINTAINER= dinoex@FreeBSD.org
-COMMENT= A threaded nntp newsreader for X
+COMMENT= Threaded nntp newsreader for X
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
@@ -18,7 +18,7 @@ RUN_DEPENDS= newsp:${PORTSDIR}/print/mp-letter
LICENSE= GPLv2
-USE_IMAKE= yes
+USES= imake
USE_XORG= xmu xpm xt sm ice xext x11
MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 CC="${CC}" \
XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults -f