aboutsummaryrefslogtreecommitdiffstats
path: root/news/newscache
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-27 18:11:07 +0800
committerbapt <bapt@FreeBSD.org>2013-12-27 18:11:07 +0800
commit81e489ad9a437268963fc9d4bb4baf0a0ac67da7 (patch)
treee716d5cedccb63349cd6547dfc8c80637cccaa83 /news/newscache
parent3187d7e40258e87da8e3442baf1c73d85f56ba6e (diff)
downloadfreebsd-ports-gnome-81e489ad9a437268963fc9d4bb4baf0a0ac67da7.tar.gz
freebsd-ports-gnome-81e489ad9a437268963fc9d4bb4baf0a0ac67da7.tar.zst
freebsd-ports-gnome-81e489ad9a437268963fc9d4bb4baf0a0ac67da7.zip
Support stage
Fix configure script with clang
Diffstat (limited to 'news/newscache')
-rw-r--r--news/newscache/Makefile9
-rw-r--r--news/newscache/pkg-plist4
2 files changed, 8 insertions, 5 deletions
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index e8334cb57375..e36b8390daac 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -11,7 +11,7 @@ DISTNAME= NewsCache-${PORTVERSION:S/.r./rc/}
MAINTAINER= ports@FreeBSD.org
COMMENT= NewsCache is a free cache server for USENET News
-LIB_DEPENDS= socket[+][+].1:${PORTSDIR}/net/libsocket++
+LIB_DEPENDS= libsocket++.so:${PORTSDIR}/net/libsocket++
USE_AUTOTOOLS= automake autoheader autoconf
AUTOMAKE_ARGS= --add-missing
@@ -20,13 +20,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
USE_RC_SUBR= ${PORTNAME}
-MAN5= newscache.conf.5
-MAN8= newscache.8 newscacheclean.8 updatenews.8
INFO= NewsCache
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e "s,-pedantic,," ${WRKSRC}/configure.in
+ ${REINPLACE_CMD} -e "s,-pedantic,," \
+ -e "s,^main,int main," \
+ ${WRKSRC}/configure.in
pre-configure:
(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./autogen)
diff --git a/news/newscache/pkg-plist b/news/newscache/pkg-plist
index f6d74ddf91be..637850c9dc3b 100644
--- a/news/newscache/pkg-plist
+++ b/news/newscache/pkg-plist
@@ -3,3 +3,7 @@ etc/newscache.conf-dist
etc/newscache.auth-dist
sbin/newscache
sbin/newscacheclean
+man/man5/newscache.conf.5.gz
+man/man8/newscache.8.gz
+man/man8/newscacheclean.8.gz
+man/man8/updatenews.8.gz