aboutsummaryrefslogtreecommitdiffstats
path: root/news/newsstar/Makefile
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-10-31 08:38:31 +0800
committermandree <mandree@FreeBSD.org>2013-10-31 08:38:31 +0800
commitefa28276c4d5a6de15c04be061484d3d57e0a9fc (patch)
treef17b8937273fd15e8252a6a121b785e25eff4c82 /news/newsstar/Makefile
parent04a3f7db82f8e7f67aabd7880e413b9eb805c365 (diff)
downloadfreebsd-ports-gnome-efa28276c4d5a6de15c04be061484d3d57e0a9fc.tar.gz
freebsd-ports-gnome-efa28276c4d5a6de15c04be061484d3d57e0a9fc.tar.zst
freebsd-ports-gnome-efa28276c4d5a6de15c04be061484d3d57e0a9fc.zip
Attempt to fix build issues.
Add SHEBANG_FILES=newsstar.in, bumping PORTREVISION.
Diffstat (limited to 'news/newsstar/Makefile')
-rw-r--r--news/newsstar/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 076cc750227b..db2fa37eb3c1 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= newsstar
PORTVERSION= 1.5.6
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= SF
@@ -16,7 +17,8 @@ BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto \
${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
GNU_CONFIGURE= yes
-USES= iconv perl5
+USES= iconv perl5 shebangfix
+SHEBANG_FILES= newsstar.in
OPTIONS_DEFINE= SSL
OPTIONS_DEFAULT= SSL
@@ -59,7 +61,6 @@ CONFIGURE_ARGS+=--with-sn-spool-dir=/var/spool/news \
CONFIGURE_ARGS+=--with-inn-path=${LOCALBASE}/news/bin
.endif
-MAN1= newsstar.1
DOCS= AUTHORS INSTALL NEWS README TODO docs/QuickStart docs/manual.txt \
docs/index.html docs/ar01s02.html docs/ar01s03.html docs/ar01s04.html \
docs/ar01s05.html docs/ar01s06.html docs/ar01s07.html docs/ar01s08.html \
@@ -70,9 +71,9 @@ EX_CONFIGS= cf.server.sample curses.cf.sample filter.pl.sample main.cf.sample \
master.ignore.sample master.score.sample newsrc.sample
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/sgml/docbook/dtd/xml|${LOCALBASE}/share/xml/docbook|' ${WRKSRC}/docs/manual.xml
- @${REINPLACE_CMD} -e 's|/usr/share/sgml/docbook/dtd/xml|${LOCALBASE}/share/xml/docbook|' ${WRKSRC}/docs/news.xml
- @${REINPLACE_CMD} -e 's|install-data-local: install-docs|install-data-local:|' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|/usr/share/sgml/docbook/dtd/xml|${LOCALBASE}/share/xml/docbook|' ${WRKSRC}/docs/manual.xml
+ ${REINPLACE_CMD} -e 's|/usr/share/sgml/docbook/dtd/xml|${LOCALBASE}/share/xml/docbook|' ${WRKSRC}/docs/news.xml
+ ${REINPLACE_CMD} -e 's|install-data-local: install-docs|install-data-local:|' ${WRKSRC}/Makefile.in
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}