aboutsummaryrefslogtreecommitdiffstats
path: root/news/nntp/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-02-20 23:36:33 +0800
committerdinoex <dinoex@FreeBSD.org>2002-02-20 23:36:33 +0800
commit58057ae85832b28b80359d810a71432f0a99559c (patch)
treed492c18c851b81e9aa4a048a58bc1ff1b49425cc /news/nntp/Makefile
parent1ab578a7dbd3614aa412b85851808b14bd3533ed (diff)
downloadfreebsd-ports-gnome-58057ae85832b28b80359d810a71432f0a99559c.tar.gz
freebsd-ports-gnome-58057ae85832b28b80359d810a71432f0a99559c.tar.zst
freebsd-ports-gnome-58057ae85832b28b80359d810a71432f0a99559c.zip
- Add Optional documentation to the package
Diffstat (limited to 'news/nntp/Makefile')
-rw-r--r--news/nntp/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index c201eb79e3e9..90c4839c9dbe 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -27,6 +27,8 @@ PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
PLIST_SUB+= NEWSCTL=${NEWSCTL:S=${PREFIX}/==}
MODIFY= conf.h Makefile
+DOCSFILES1= AUTHORIZE CHANGES README README-conf.h SYSLOG doc/rfc977
+DOCSFILES2= server support xfer xmit
NEWSBIN?= ${PREFIX}/news/cnewsbin
NEWSCTL?= ${PREFIX}/news/lib
@@ -53,5 +55,15 @@ pre-configure:
post-install:
${INSTALL_DATA} ${WRKSRC}/overview.fmt ${NEWSCTL}/overview.fmt
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCSFILES1}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.for i in ${DOCSFILES2}
+ ${INSTALL_DATA} ${WRKSRC}/${i}/README ${DOCSDIR}/${i}-README
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>