aboutsummaryrefslogtreecommitdiffstats
path: root/news/nntpcache/files
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-03-30 01:28:56 +0800
committeradamw <adamw@FreeBSD.org>2014-03-30 01:28:56 +0800
commit2a32fb6bd2fd16d6ee1c24024785a8ed80edf867 (patch)
tree1b1cbaaa8a1ad8875cf82eefa0bfb6687b917752 /news/nntpcache/files
parent7cfe282cf08cadcca68d4464eb91f436261ff44f (diff)
downloadfreebsd-ports-gnome-2a32fb6bd2fd16d6ee1c24024785a8ed80edf867.tar.gz
freebsd-ports-gnome-2a32fb6bd2fd16d6ee1c24024785a8ed80edf867.tar.zst
freebsd-ports-gnome-2a32fb6bd2fd16d6ee1c24024785a8ed80edf867.zip
Add stage support to news, and improve correctness.
I am not touching the husky ports with a 10 foot pole. atp: stage, improve pkg-message crashmail: stage diablo: too wacky to stage, but convert WITH_* to OPTIONS, unmute commands that shouldn't be muted, use :MDOCS fidogate-ds: stage, OPTIONS, treat examples as EXAMPLES, not DOCS, handle /var/* in the plist properly golded+: stage, OPTIONS, protect examples behind %%PORTEXAMPLES%% nntpbtr: this was an unbelievably PITA stage, add missing prototypes, add missing return types, rename patch files to what they actually patch nntpcache: stage support, required lots of Makefile.in patching, call submakes correctly, handle config files properly nzbperl: stage, use OPTIONS, remove obsolete pkg-message papercut: stage, handle config file properly py-pynzb: stage, use OPTIONS helper to avoid bsd.port.options.mk inclusion s-news: stage slrnconf: stage slrnface: stage, install required files to datadir, not examplesdir, generate proper pkg-message sn: stage
Diffstat (limited to 'news/nntpcache/files')
-rw-r--r--news/nntpcache/files/patch-cf_Makefile.in21
-rw-r--r--news/nntpcache/files/patch-http_Makefile.in17
-rw-r--r--news/nntpcache/files/patch-innreport_Makefile.in17
-rw-r--r--news/nntpcache/files/patch-pgp_Makefile.in15
-rw-r--r--news/nntpcache/files/patch-unixauth_Makefile.in15
5 files changed, 85 insertions, 0 deletions
diff --git a/news/nntpcache/files/patch-cf_Makefile.in b/news/nntpcache/files/patch-cf_Makefile.in
new file mode 100644
index 000000000000..f218ba17ae60
--- /dev/null
+++ b/news/nntpcache/files/patch-cf_Makefile.in
@@ -0,0 +1,21 @@
+--- cf/Makefile.in.orig 2006-03-05 16:49:25.000000000 -0500
++++ cf/Makefile.in 2014-03-29 12:18:45.000000000 -0400
+@@ -271,15 +271,15 @@
+ echo @VERSION@ >$@
+
+ install-data-hook:
+- for f in $(distf); do { cd $(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
++ for f in $(distf); do { cd $(DESTDIR)$(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
+
+ nntpcache.config-dist : nnconf.cf
+ sed -e 's/^ *[a-zA-Z_][a-zA-Z_]* //;s/"//g' <nnconf.cf >$@
+
+ # this is ugly, but more flexible than merely redefining INSTALL_DATA
+ install-data-local:
+- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
+- cd $(localstatedir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(localstate_DATA) && chown @nntpcacheUID@ $(localstate_DATA) && chgrp @nntpcacheGID@ $(localstate_DATA)
++ cd $(DESTDIR)$(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
++ cd $(DESTDIR)$(localstatedir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(localstate_DATA) && chown @nntpcacheUID@ $(localstate_DATA) && chgrp @nntpcacheGID@ $(localstate_DATA)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/news/nntpcache/files/patch-http_Makefile.in b/news/nntpcache/files/patch-http_Makefile.in
new file mode 100644
index 000000000000..fe73bcffa60b
--- /dev/null
+++ b/news/nntpcache/files/patch-http_Makefile.in
@@ -0,0 +1,17 @@
+--- http/Makefile.in.orig 2014-03-29 12:19:41.000000000 -0400
++++ http/Makefile.in 2014-03-29 12:20:08.000000000 -0400
+@@ -216,10 +216,10 @@
+
+
+ install-data-local:
+- -mkdir $(sysconfdir)/http
+- cp $(httpdata) $(sysconfdir)/http
+- cd $(sysconfdir)/http && chown @nntpcacheUID@ $(ch)
+- cd $(sysconfdir)/http && chgrp @nntpcacheUID@ $(ch)
++ -mkdir $(DESTDIR)$(sysconfdir)/http
++ cp $(httpdata) $(DESTDIR)$(sysconfdir)/http
++ cd $(DESTDIR)$(sysconfdir)/http && chown @nntpcacheUID@ $(ch)
++ cd $(DESTDIR)$(sysconfdir)/http && chgrp @nntpcacheUID@ $(ch)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/news/nntpcache/files/patch-innreport_Makefile.in b/news/nntpcache/files/patch-innreport_Makefile.in
new file mode 100644
index 000000000000..3afc775d1fd2
--- /dev/null
+++ b/news/nntpcache/files/patch-innreport_Makefile.in
@@ -0,0 +1,17 @@
+--- innreport/Makefile.in.orig 2014-03-29 12:22:45.000000000 -0400
++++ innreport/Makefile.in 2014-03-29 12:23:58.000000000 -0400
+@@ -265,10 +265,10 @@
+
+ # the trailing slash is to force symlink transversal
+ install-data-local:
+- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
+- -mkdir $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
+- chown @nntpcacheUID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
+- chgrp @nntpcacheGID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
++ cd $(DESTDIR)$(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
++ -mkdir $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
++ chown @nntpcacheUID@ $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
++ chgrp @nntpcacheGID@ $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/news/nntpcache/files/patch-pgp_Makefile.in b/news/nntpcache/files/patch-pgp_Makefile.in
new file mode 100644
index 000000000000..abd80d603fbd
--- /dev/null
+++ b/news/nntpcache/files/patch-pgp_Makefile.in
@@ -0,0 +1,15 @@
+--- pgp/Makefile.in.orig 2014-03-29 12:21:08.000000000 -0400
++++ pgp/Makefile.in 2014-03-29 12:21:29.000000000 -0400
+@@ -236,10 +236,10 @@
+
+ # the trailing slash is to force symlink transversal
+ install-data-local:
+- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
++ cd $(DESTDIR)$(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
+
+ install-data-hook:
+- for f in $(sysconf_DATA); do { cd $(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
++ for f in $(sysconf_DATA); do { cd $(DESTDIR)$(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/news/nntpcache/files/patch-unixauth_Makefile.in b/news/nntpcache/files/patch-unixauth_Makefile.in
new file mode 100644
index 000000000000..9d47abf4f8b2
--- /dev/null
+++ b/news/nntpcache/files/patch-unixauth_Makefile.in
@@ -0,0 +1,15 @@
+--- unixauth/Makefile.in.orig 2014-03-29 12:25:30.000000000 -0400
++++ unixauth/Makefile.in 2014-03-29 12:26:15.000000000 -0400
+@@ -327,9 +327,9 @@
+
+
+ install-exec-hook:
+- chown root $(libexecdir)/unixauth
+- chgrp @nntpcacheGID@ $(libexecdir)/unixauth
+- chmod u+s,g+x,o-x $(libexecdir)/unixauth
++ chown root $(DESTDIR)$(libexecdir)/unixauth
++ chgrp @nntpcacheGID@ $(DESTDIR)$(libexecdir)/unixauth
++ chmod u+s,g+x,o-x $(DESTDIR)$(libexecdir)/unixauth
+
+ %.ext : %.c %.h $(top_srcdir)/config.h $(top_srcdir)/scripts/genextern.sh
+ CPP="$(CPP)";export CPP; sh $(top_srcdir)/scripts/genextern.sh $< > $@.tmp $(DEFS) $(INCLUDES) $(CPPFLAGS) && mv -f $@.tmp $@ || rm -f $@.tmp