aboutsummaryrefslogtreecommitdiffstats
path: root/news/p5-Gateway/Makefile
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-05-04 23:11:40 +0800
committermph <mph@FreeBSD.org>1998-05-04 23:11:40 +0800
commit1c78a9484e9dcff03fd4e9a013c89b5f093f946c (patch)
tree8a797f20a3eed985a883550e6856e5bf9efbf29c /news/p5-Gateway/Makefile
parent929293de4405174bc2ce62bc88520caeb1333925 (diff)
downloadfreebsd-ports-gnome-1c78a9484e9dcff03fd4e9a013c89b5f093f946c.tar.gz
freebsd-ports-gnome-1c78a9484e9dcff03fd4e9a013c89b5f093f946c.tar.zst
freebsd-ports-gnome-1c78a9484e9dcff03fd4e9a013c89b5f093f946c.zip
Import of p5-Gateway, a Perl 5 module that provides a framework for
Netnews moderation and gateway scripts. PR: 6501 Submitted by: Don Croyle <croyle@gelemna.ft-wayne.in.us>
Diffstat (limited to 'news/p5-Gateway/Makefile')
-rw-r--r--news/p5-Gateway/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/news/p5-Gateway/Makefile b/news/p5-Gateway/Makefile
new file mode 100644
index 000000000000..999a4e433afe
--- /dev/null
+++ b/news/p5-Gateway/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Gateway
+# Version required: 0.42
+# Date created: January 2, 1998
+# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
+#
+# $Id$
+#
+
+DISTNAME= Gateway-0.42
+PKGNAME= p5-Gateway-0.42
+CATEGORIES= news perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= News
+
+MAINTAINER= croyle@gelemna.ft-wayne.in.us
+
+BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/News/Article.pm:${PORTSDIR}/news/p5-News-Article
+RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/News/Article.pm:${PORTSDIR}/news/p5-News-Article
+
+USE_PERL5= yes
+
+MAN3= News::Gateway.3
+MANPREFIX= ${PREFIX}/lib/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+.include <bsd.port.mk>