aboutsummaryrefslogtreecommitdiffstats
path: root/news/pan/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-13 23:37:58 +0800
committerkwm <kwm@FreeBSD.org>2011-08-13 23:37:58 +0800
commitad4b0396c76bbb5637b72052c32967a57b206a74 (patch)
treeecdf08ed3a61555fde3397d264b2c70123ff2862 /news/pan/Makefile
parent9acbf00564b751077df41d3befa05c523013b4e4 (diff)
downloadfreebsd-ports-gnome-ad4b0396c76bbb5637b72052c32967a57b206a74.tar.gz
freebsd-ports-gnome-ad4b0396c76bbb5637b72052c32967a57b206a74.tar.zst
freebsd-ports-gnome-ad4b0396c76bbb5637b72052c32967a57b206a74.zip
Update to 0.135.
Add optional GTK+3 UI option. Add LICENSE. PR: ports/159723 (based on) Submitted by: "Conrad J. Sabatier" <conrads@cox.net>
Diffstat (limited to 'news/pan/Makefile')
-rw-r--r--news/pan/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 980c3fd6eb58..394e79896abd 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -7,30 +7,41 @@
#
PORTNAME= pan
-PORTVERSION= 0.134
+PORTVERSION= 0.135
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Threaded GTK+2 newsreader based on Agent for Windows
+COMMENT= Threaded GTK+ newsreader based on Agent for Windows
+
+LICENSE= GPLv2
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
gmime-2.4.6:${PORTSDIR}/mail/gmime24
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intlhack
+USE_GNOME= gnomehack intlhack
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib -lgnuregex"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnuregex"
-OPTIONS= GTKSPELL "Enable spell checking support" on
+OPTIONS= GTKSPELL "Enable spell checking support (gtk+2 only)" on \
+ GTK3 "Build with gtk+3 based UI instead of gtk+2" off
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_GTKSPELL)
+.if defined(WITHOUT_GTK3)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+=--without-gtk3
+.else
+USE_GNOME+= gtk30
+CONFIGURE_ARGS+=--with-gtk3
+.endif
+
+.if defined(WITHOUT_GTKSPELL) || defined(WITH_GTK3)
CONFIGURE_ARGS+= --without-gtkspell
.else
LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell