aboutsummaryrefslogtreecommitdiffstats
path: root/news/pan
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-04-24 05:25:44 +0800
committermezz <mezz@FreeBSD.org>2007-04-24 05:25:44 +0800
commit4bdc7dc16f2609af674250986ac8ba0c5949480b (patch)
tree6a060a6e18ce874a8c8ba194b9b4ed33fbdacccf /news/pan
parentee23bc4d1e9433bd997ba32f48ddb39414650e24 (diff)
downloadfreebsd-ports-gnome-4bdc7dc16f2609af674250986ac8ba0c5949480b.tar.gz
freebsd-ports-gnome-4bdc7dc16f2609af674250986ac8ba0c5949480b.tar.zst
freebsd-ports-gnome-4bdc7dc16f2609af674250986ac8ba0c5949480b.zip
Change this patch to a better fix, bump the PORTREVISION.
GNOME Bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=432387 Submitted by: Charles Kerr (developer) Tested by: pav
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile1
-rw-r--r--news/pan/files/patch-pan_data_article.cc9
2 files changed, 6 insertions, 4 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 5edf474923d8..984b23d5afe3 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pan
PORTVERSION= 0.128
+PORTREVISION= 1
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
diff --git a/news/pan/files/patch-pan_data_article.cc b/news/pan/files/patch-pan_data_article.cc
index c461c7d93f26..e050cb84cbbb 100644
--- a/news/pan/files/patch-pan_data_article.cc
+++ b/news/pan/files/patch-pan_data_article.cc
@@ -1,11 +1,12 @@
---- pan/data/article.cc.orig Sun Apr 22 15:17:04 2007
-+++ pan/data/article.cc Sun Apr 22 15:17:44 2007
-@@ -153,7 +153,7 @@
+--- pan/data/article.cc.orig Mon Apr 23 16:21:51 2007
++++ pan/data/article.cc Mon Apr 23 16:23:29 2007
+@@ -153,7 +153,8 @@
kc = &key.back();
mc = &mid.back();
- ke = key.str + 1 + std::max (int(b), (int)minlen - UCHAR_MAX);
-+ ke = key.str + 1 + std::max ((char)b, (char)(minlen - UCHAR_MAX));
++ ke = std::max (key.str + b + 1,
++ key.str + key.len - UCHAR_MAX);
while (kc>ke)
if (*kc-- != *mc--) { ++kc; break; }
const size_t e (&key.back() - kc);