aboutsummaryrefslogtreecommitdiffstats
path: root/news/pan
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-09-14 21:25:15 +0800
committersobomax <sobomax@FreeBSD.org>2001-09-14 21:25:15 +0800
commitcbc9d03f454736abcba96c9c825ac4ea26356cdc (patch)
tree33ca56eb96bf9b6aaebeb18e3a26f38eff4933e8 /news/pan
parentd7900b2b6c7b8844f5913189c4d50e6e5cc90ac5 (diff)
downloadfreebsd-ports-gnome-cbc9d03f454736abcba96c9c825ac4ea26356cdc.tar.gz
freebsd-ports-gnome-cbc9d03f454736abcba96c9c825ac4ea26356cdc.tar.zst
freebsd-ports-gnome-cbc9d03f454736abcba96c9c825ac4ea26356cdc.zip
Fix a potential useless CPU time eating.
PR: 30554 Submitted by: Jose M. Alcaide <jose@we.lc.ehu.es>, Chris Vance
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile1
-rw-r--r--news/pan/files/patch-pan::queue.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 2c9aa5b4096c..679aa4172ed5 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pan
PORTVERSION= 0.10.0.90
+PORTREVISION= 1
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/${PORTVERSION}/SOURCE/
diff --git a/news/pan/files/patch-pan::queue.c b/news/pan/files/patch-pan::queue.c
new file mode 100644
index 000000000000..e4c2495c0ec7
--- /dev/null
+++ b/news/pan/files/patch-pan::queue.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- pan/queue.c 2001/09/14 13:20:29 1.1
++++ pan/queue.c 2001/09/14 13:20:44
+@@ -1202,7 +1202,7 @@
+ pthread_mutex_lock (&queue_lock);
+ gettimeofday (&now, NULL);
+ timeout.tv_sec = now.tv_sec + TIMEOUT_SECS;
+- timeout.tv_nsec = timeout.tv_sec;
++ timeout.tv_nsec = 0;
+ retcode = pthread_cond_timedwait(&qcond, &queue_lock, &timeout);
+ pthread_mutex_unlock (&queue_lock);
+