aboutsummaryrefslogtreecommitdiffstats
path: root/news/pyne
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /news/pyne
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'news/pyne')
-rw-r--r--news/pyne/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/news/pyne/Makefile b/news/pyne/Makefile
index cf6aa88e1db7..c135f02526fe 100644
--- a/news/pyne/Makefile
+++ b/news/pyne/Makefile
@@ -21,6 +21,10 @@ INSTALL_WRKSRC= ${WRKDIR}/${DISTNAME}/src/po
USE_GNOME= pygtk2
USE_PYTHON= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's/# Originally/# coding:latin1/g' \
+ ${WRKSRC}/src/po/pygettext.py
+
pre-build:
@${ECHO_CMD} "#!/bin/sh" > ${WRKDIR}/pyne.sh
@${ECHO_CMD} "exec ${PYTHON_CMD} -O ${PYTHON_SITELIBDIR}/pyne/pyne.py \$$*" >> ${WRKDIR}/pyne.sh