aboutsummaryrefslogtreecommitdiffstats
path: root/news/s-news/files
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-03-30 01:28:56 +0800
committeradamw <adamw@FreeBSD.org>2014-03-30 01:28:56 +0800
commit2a32fb6bd2fd16d6ee1c24024785a8ed80edf867 (patch)
tree1b1cbaaa8a1ad8875cf82eefa0bfb6687b917752 /news/s-news/files
parent7cfe282cf08cadcca68d4464eb91f436261ff44f (diff)
downloadfreebsd-ports-gnome-2a32fb6bd2fd16d6ee1c24024785a8ed80edf867.tar.gz
freebsd-ports-gnome-2a32fb6bd2fd16d6ee1c24024785a8ed80edf867.tar.zst
freebsd-ports-gnome-2a32fb6bd2fd16d6ee1c24024785a8ed80edf867.zip
Add stage support to news, and improve correctness.
I am not touching the husky ports with a 10 foot pole. atp: stage, improve pkg-message crashmail: stage diablo: too wacky to stage, but convert WITH_* to OPTIONS, unmute commands that shouldn't be muted, use :MDOCS fidogate-ds: stage, OPTIONS, treat examples as EXAMPLES, not DOCS, handle /var/* in the plist properly golded+: stage, OPTIONS, protect examples behind %%PORTEXAMPLES%% nntpbtr: this was an unbelievably PITA stage, add missing prototypes, add missing return types, rename patch files to what they actually patch nntpcache: stage support, required lots of Makefile.in patching, call submakes correctly, handle config files properly nzbperl: stage, use OPTIONS, remove obsolete pkg-message papercut: stage, handle config file properly py-pynzb: stage, use OPTIONS helper to avoid bsd.port.options.mk inclusion s-news: stage slrnconf: stage slrnface: stage, install required files to datadir, not examplesdir, generate proper pkg-message sn: stage
Diffstat (limited to 'news/s-news/files')
-rw-r--r--news/s-news/files/patch-Makefile.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/news/s-news/files/patch-Makefile.in b/news/s-news/files/patch-Makefile.in
index de222774d1e1..0e06d5ac2ec6 100644
--- a/news/s-news/files/patch-Makefile.in
+++ b/news/s-news/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sat May 18 21:23:03 2002
-+++ Makefile.in Sat Jul 17 21:03:08 2004
+--- Makefile.in.orig 2002-05-18 15:23:03.000000000 -0400
++++ Makefile.in 2014-03-29 13:01:10.000000000 -0400
@@ -113,7 +113,7 @@
$(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/$$p;\
done
@@ -9,11 +9,15 @@
done
$(INSTALL_DIRECTORY) $(DESTDIR)$(mandir)/man1
for p in $(MAN1PAGES); do\
-@@ -125,10 +125,9 @@
+@@ -123,12 +123,11 @@
+ for p in $(MAN8PAGES); do\
+ $(INSTALL_DATA) $$p $(DESTDIR)$(mandir)/man8/$$p;\
done
- $(INSTALL_VARDIR) $(spooldir)
- $(INSTALL_VARDIR) $(confdir)
+- $(INSTALL_VARDIR) $(spooldir)
+- $(INSTALL_VARDIR) $(confdir)
- $(INSTALL_VARDIR) $(confdir)/suck
++ $(INSTALL_VARDIR) $(DESTDIR)$(spooldir)
++ $(INSTALL_VARDIR) $(DESTDIR)$(confdir)
for d in $(DATA); do\
if test ! -e $(DESTDIR)$(confdir)/$$d; then\
- $(INSTALL_VARDATA) data/$$d $(DESTDIR)$(confdir)/$$d;\