aboutsummaryrefslogtreecommitdiffstats
path: root/news/slrn/Makefile
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-12-23 02:26:08 +0800
committerjohans <johans@FreeBSD.org>2012-12-23 02:26:08 +0800
commit9899774354f639ecc1e704f834f0c7dc67172cc0 (patch)
tree53bdfe850daeb9a4406999363a229d98946da7c6 /news/slrn/Makefile
parent20a3e127051b74785c13119fe5984fc3f90637b2 (diff)
downloadfreebsd-ports-gnome-9899774354f639ecc1e704f834f0c7dc67172cc0.tar.gz
freebsd-ports-gnome-9899774354f639ecc1e704f834f0c7dc67172cc0.tar.zst
freebsd-ports-gnome-9899774354f639ecc1e704f834f0c7dc67172cc0.zip
- Upgrade to slrn 1.0.1
- Update MASTER_SITES
Diffstat (limited to 'news/slrn/Makefile')
-rw-r--r--news/slrn/Makefile34
1 files changed, 13 insertions, 21 deletions
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index 024eaf76a56c..3c910c189ed4 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -1,19 +1,11 @@
-# New ports collection makefile for: slrn
-# Date created: 28 March 1997
-# Whom: Carey Jones <mcj@acquiesce.org>
-#
+# Created by: Carey Jones <mcj@acquiesce.org>
# $FreeBSD$
-#
PORTNAME= slrn
-PORTVERSION= 0.9.9p1
-PORTREVISION= 3
+PORTVERSION= 1.0.1
CATEGORIES= news ipv6
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
- ftp://angel.sovam.com/pub/tools/net/news/ \
- ftp://ftp.fu-berlin.de/pub/unix/news/slrn/ \
- ftp://ftp.ntua.gr/pub/lang/slang/slrn/ \
- ftp://ftp.plig.org/pub/slrn/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME} \
+ http://www.jedsoft.org/slrn/download/
MAINTAINER= johans@FreeBSD.org
COMMENT= SLang-based newsreader
@@ -25,6 +17,14 @@ CONFLICTS_INSTALL= ja-slrn-[0-9]*
USE_GMAKE= yes
USE_ICONV= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-ipv6 --disable-inews --with-slrnpull \
+ --with-libiconv-prefix=${LOCALBASE}
+
+ALL_TARGET= all
+
+MAN1= slrn.1 slrnpull.1
+
OPTIONS_DEFINE= SSL DEVIEW
OPTIONS_DEFAULT=SSL
@@ -38,10 +38,6 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-ipv6 --disable-inews --with-slrnpull \
- --with-libiconv-prefix=${LOCALBASE}
-
.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= YES
CONFIGURE_ARGS+= --with-ssl
@@ -52,15 +48,11 @@ LIB_DEPENDS+= uu:${PORTSDIR}/converters/uulib
CONFIGURE_ARGS+= --with-uulib
.endif
-.if empty(PORT_OPTIONS:MDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
# Use dummy target rather than rewriting makefile
CONFIGURE_ARGS+= --with-docdir=${WRKSRC}/dummy
.endif
-ALL_TARGET= all
-
-MAN1= slrn.1 slrnpull.1
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/lib/sendmail,/usr/sbin/sendmail,' \
${WRKSRC}/src/slrnfeat.hin