aboutsummaryrefslogtreecommitdiffstats
path: root/news/slrn/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-04-19 09:08:14 +0800
committerpetef <petef@FreeBSD.org>2002-04-19 09:08:14 +0800
commit9d74629523b0c2fe5f02ba4bc3f37c73af058448 (patch)
treed2046d00f2d79c98d2d372a9a2a9338e0900e50a /news/slrn/Makefile
parent16f2303835ab5531f089069598152b09b7d6065a (diff)
downloadfreebsd-ports-gnome-9d74629523b0c2fe5f02ba4bc3f37c73af058448.tar.gz
freebsd-ports-gnome-9d74629523b0c2fe5f02ba4bc3f37c73af058448.tar.zst
freebsd-ports-gnome-9d74629523b0c2fe5f02ba4bc3f37c73af058448.zip
Add support for localization.
PR: 36351 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'news/slrn/Makefile')
-rw-r--r--news/slrn/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index 0acb0111a720..f21553d7357a 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -19,13 +19,17 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= petef@FreeBSD.org
-LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang \
+ intl.2:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-ipv6 --disable-inews --with-slrnpull
+CONFIGURE_ARGS= --enable-ipv6 --disable-inews --with-slrnpull \
+ --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
.if !defined(WITHOUT_SSL)
USE_OPENSSL= YES
@@ -45,6 +49,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/slrnpull ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/examples/slrn
${INSTALL_DATA} ${WRKSRC}/doc/slrn.rc ${PREFIX}/share/examples/slrn
+ (cd ${WRKSRC}/po; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install)
@${MKDIR} ${PREFIX}/share/examples/slrn/slrnpull
.for file in FAQ README SETUP score slrn.rc slrnpull.conf slrnpull.sh
${INSTALL_DATA} ${WRKSRC}/doc/slrnpull/${file} ${PREFIX}/share/examples/slrn/slrnpull