aboutsummaryrefslogtreecommitdiffstats
path: root/news/slrn
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-06-15 16:27:05 +0800
committerjohans <johans@FreeBSD.org>2012-06-15 16:27:05 +0800
commit8193487c4bae613032535f1923f039d25d4e12bd (patch)
tree771a563ed3c634131b333f658610ecfbcef991e8 /news/slrn
parente1eb449b85e802162a6b7a35cbc2d3fa8fed043f (diff)
downloadfreebsd-ports-gnome-8193487c4bae613032535f1923f039d25d4e12bd.tar.gz
freebsd-ports-gnome-8193487c4bae613032535f1923f039d25d4e12bd.tar.zst
freebsd-ports-gnome-8193487c4bae613032535f1923f039d25d4e12bd.zip
- Add conflicts
- Use new style options - Remove unneeded library version numbers - No functional changes
Diffstat (limited to 'news/slrn')
-rw-r--r--news/slrn/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index b8a38ece4d55..79d63230c272 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -18,14 +18,15 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
MAINTAINER= johans@FreeBSD.org
COMMENT= SLang-based newsreader
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang2
+
+CONFLICTS_INSTALL= ja-slrn-[0-9]*
USE_GMAKE= yes
USE_ICONV= yes
-OPTIONS= NLS "Native Language Support via gettext utilities" on \
- SSL "Adds support for SSL (Secure Socket Layer)" on \
- DEVIEW "Enable uulib for multiple de-/encoding" off
+OPTIONS_DEFINE= SSL DEVIEW
+OPTIONS_DEFAULT=SSL
.include <bsd.port.options.mk>
@@ -41,17 +42,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-ipv6 --disable-inews --with-slrnpull \
--with-libiconv-prefix=${LOCALBASE}
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= YES
CONFIGURE_ARGS+= --with-ssl
.endif
-.if defined(WITH_DEVIEW)
-LIB_DEPENDS+= uu.3:${PORTSDIR}/converters/uulib
+.if ${PORT_OPTIONS:MDEVIEW}
+LIB_DEPENDS+= uu:${PORTSDIR}/converters/uulib
CONFIGURE_ARGS+= --with-uulib
.endif
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
# Use dummy target rather than rewriting makefile
CONFIGURE_ARGS+= --with-docdir=${WRKSRC}/dummy
.endif