aboutsummaryrefslogtreecommitdiffstats
path: root/news/sn/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-24 00:30:00 +0800
committerkrion <krion@FreeBSD.org>2004-02-24 00:30:00 +0800
commit4b33370430c03fbf13d67a46c06fdb0ebb800771 (patch)
tree01e8ff938d85413db0fa9aeb57c6525a0bc4088c /news/sn/Makefile
parentf47e88f5cd291c131e18d1bfebb1d11c16bc6c7b (diff)
downloadfreebsd-ports-gnome-4b33370430c03fbf13d67a46c06fdb0ebb800771.tar.gz
freebsd-ports-gnome-4b33370430c03fbf13d67a46c06fdb0ebb800771.tar.zst
freebsd-ports-gnome-4b33370430c03fbf13d67a46c06fdb0ebb800771.zip
Add sn 0.3.6,
sn a small news system for small sites serving perhaps a few dozen newsgroups, and with a slow connection to the internet. It is similar to Leafnode. The target user is a home or SOHO with a single modem connection to the Internet, maybe running IP masq or similar, and serving a few workstations. PR: ports/63263 Submitted by: Andreas Fehlner <fehlner@gmx.del>
Diffstat (limited to 'news/sn/Makefile')
-rw-r--r--news/sn/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/news/sn/Makefile b/news/sn/Makefile
new file mode 100644
index 000000000000..aea49efeabb7
--- /dev/null
+++ b/news/sn/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: sn
+# Date created: 2004-02-21
+# Whom: Andreas Fehlner <fehlner@gmx.del>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sn
+PORTVERSION= 0.3.6
+CATEGORIES= news
+MASTER_SITES= http://www.infa.abo.fi/~patrik/sn/files/
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Small news system for small sites serving
+
+DOCS= README CHANGES FAQ INSTALL INTERNALS \
+ THANKS TODO INSTALL.notes INSTALL.notes2 \
+ INSTALL.run INSTALL.upgrade
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+MAN8= sn.8 sncancel.8 sncat.8 sndelgroup.8 sndumpdb.8 \
+ snexpire.8 snfetch.8 snget.8 sngetd.8 snmail.8 \
+ snnewgroup.8 snntpd.8 snprimedb.8 snscan.8 snsend.8 \
+ snsplit.8 snstore.8
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^PREFIX|#PREFIX|g' ${WRKSRC}/Makefile
+
+pre-install:
+ @${MKDIR} /var/spool/news
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>