aboutsummaryrefslogtreecommitdiffstats
path: root/news/ubh
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /news/ubh
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'news/ubh')
-rw-r--r--news/ubh/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/news/ubh/Makefile b/news/ubh/Makefile
index 2c1841ed5b39..9f2a0b4e8801 100644
--- a/news/ubh/Makefile
+++ b/news/ubh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ubh
PORTVERSION= 2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news graphics
MASTER_SITES= http://ubh.sourceforge.net/download/
@@ -18,15 +18,11 @@ RUN_DEPENDS= \
p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32
NO_BUILD= YES
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ubh
OPTIONS_DEFINE= DOCS
-pre-patch:
- @${MV} ${WRKSRC}/ubh ${WRKSRC}/ubh.old
- @${SED} -e '1,1s:/usr/bin/perl:${PERL5}:' \
- ${WRKSRC}/ubh.old > ${WRKSRC}/ubh
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ubh ${STAGEDIR}${PREFIX}/bin
${CP} -R ${WRKSRC}/examples ${STAGEDIR}${PREFIX}/share/ubh