aboutsummaryrefslogtreecommitdiffstats
path: root/news/yencode/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-25 15:35:57 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-25 15:35:57 +0800
commit97a44dc92493ecd7c091d02e28c2fe77f235cf06 (patch)
tree4f59cf13e7b6feee2468e2867fd250cb32a635b9 /news/yencode/Makefile
parenta882f020d88c182295a14179e0ac1cd001ff8dff (diff)
downloadfreebsd-ports-gnome-97a44dc92493ecd7c091d02e28c2fe77f235cf06.tar.gz
freebsd-ports-gnome-97a44dc92493ecd7c091d02e28c2fe77f235cf06.tar.zst
freebsd-ports-gnome-97a44dc92493ecd7c091d02e28c2fe77f235cf06.zip
add yencode 0.46
A free (GPL) encoder and decoder for the yEnc Usenet file format
Diffstat (limited to 'news/yencode/Makefile')
-rw-r--r--news/yencode/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/news/yencode/Makefile b/news/yencode/Makefile
new file mode 100644
index 000000000000..c6c9b1b41b0b
--- /dev/null
+++ b/news/yencode/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: yencode
+# Date created: Mar 24, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= yencode
+PORTVERSION= 0.46
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ iconv:${PORTSDIR}/converters/libiconv \
+ intl:${PORTSDIR}/devel/gettext
+
+USE_BISON= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= ydecode.1 yencode.1 ypost.1
+MAN5= ypostrc.5
+
+.include <bsd.port.mk>