aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /news
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'news')
-rw-r--r--news/grn/Makefile2
-rw-r--r--news/pan/Makefile2
-rw-r--r--news/pan2/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
index af69a2e2f1ff..aa5a3cf28126 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= glibpath="${GLIB_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 58d3a1a8f05c..80d02c1d8cc9 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --enable-html
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/news/pan2/Makefile b/news/pan2/Makefile
index 58d3a1a8f05c..80d02c1d8cc9 100644
--- a/news/pan2/Makefile
+++ b/news/pan2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --enable-html
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \