aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-05-18 17:55:25 +0800
committerkris <kris@FreeBSD.org>2003-05-18 17:55:25 +0800
commit6f07558a470ffa1d87d80af0b4007d14060e7808 (patch)
tree0a6c4132fdb6c80f82e2405cebd8936484804de4 /news
parenta06e65bebb2b10d4b6f5dfcff23f08e8d38c918a (diff)
downloadfreebsd-ports-gnome-6f07558a470ffa1d87d80af0b4007d14060e7808.tar.gz
freebsd-ports-gnome-6f07558a470ffa1d87d80af0b4007d14060e7808.tar.zst
freebsd-ports-gnome-6f07558a470ffa1d87d80af0b4007d14060e7808.zip
BROKEN on 5.1: bad C++
Diffstat (limited to 'news')
-rw-r--r--news/PicMonger/Makefile8
-rw-r--r--news/newscache/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/news/PicMonger/Makefile b/news/PicMonger/Makefile
index c01937c8192e..9e9a0ad59539 100644
--- a/news/PicMonger/Makefile
+++ b/news/PicMonger/Makefile
@@ -16,9 +16,15 @@ COMMENT= An automated USENET (NNT) picture decoding client
LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk--
RUN_DEPENDS= mpack:${PORTSDIR}/converters/mpack
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= imlib
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index e270b484eb42..94ca2199005c 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -17,6 +17,12 @@ COMMENT= NewsCache is a free cache server for USENET News
LIB_DEPENDS= socket[+][+].1:${PORTSDIR}/net/libsocket++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_AUTOMAKE_VER= 15
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -28,4 +34,4 @@ MAN8= newscache.8 newscacheclean.8 updatenews.8
post-patch:
cd ${WRKSRC}; ./autogen
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>