aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2017-06-10 02:47:56 +0800
committertdb <tdb@FreeBSD.org>2017-06-10 02:47:56 +0800
commit00af31f9a0c31d8828cd9bb4c98a6c04727acbac (patch)
treeea0a06c4e8b0ba987afdddaf48ecc7e3cab6d433 /news
parent9c64e567042dec2c839f45968f3ae737d2d44f5a (diff)
downloadfreebsd-ports-gnome-00af31f9a0c31d8828cd9bb4c98a6c04727acbac.tar.gz
freebsd-ports-gnome-00af31f9a0c31d8828cd9bb4c98a6c04727acbac.tar.zst
freebsd-ports-gnome-00af31f9a0c31d8828cd9bb4c98a6c04727acbac.zip
New port: news/py-sabyenc
Modified the original yenc module by Alessandro Duca alessandro.duca@gmail.com for use within SABnzbd. The module was extended to do header parsing and full yEnc decoding from a Python list of chunks, the way in which data is retrieved from usenet. This is particularly beneficial when SSL is enabled, which limits the size of each chunk to 16K. Parsing these chunks in Python is much more costly. Additionally, this module releases Python's GIL during decoding, greatly increasing performance of the overall download process. WWW: https://github.com/sabnzbd/sabyenc PR: 218722 Submitted by: Ralf van der Enden <tremere@cainites.net>
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/py-sabyenc/Makefile20
-rw-r--r--news/py-sabyenc/distinfo3
-rw-r--r--news/py-sabyenc/pkg-descr11
4 files changed, 35 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index 06b8664c2eea..1de5617072ec 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -59,6 +59,7 @@
SUBDIR += pgpmoose
SUBDIR += plor
SUBDIR += py-pynzb
+ SUBDIR += py-sabyenc
SUBDIR += py-twistedNews
SUBDIR += py-yenc
SUBDIR += rawdog
diff --git a/news/py-sabyenc/Makefile b/news/py-sabyenc/Makefile
new file mode 100644
index 000000000000..79bef4507711
--- /dev/null
+++ b/news/py-sabyenc/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ralf van der Enden <tremere@cainites.net>
+# $FreeBSD$
+
+PORTNAME= sabyenc
+PORTVERSION= 3.0.2
+DISTVERSIONPREFIX= v
+CATEGORIES= news python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tremere@cainites.net
+COMMENT= Python yEnc package optimized for use within SABnzbd
+
+LICENSE= GPLv3
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= sabnzbd
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/news/py-sabyenc/distinfo b/news/py-sabyenc/distinfo
new file mode 100644
index 000000000000..9458f343410d
--- /dev/null
+++ b/news/py-sabyenc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496981772
+SHA256 (sabnzbd-sabyenc-v3.0.2_GH0.tar.gz) = 72305bdacfb4f82764e7f3e33a7001983f9af5c8d633cbf57e950b570a56e55d
+SIZE (sabnzbd-sabyenc-v3.0.2_GH0.tar.gz) = 16080819
diff --git a/news/py-sabyenc/pkg-descr b/news/py-sabyenc/pkg-descr
new file mode 100644
index 000000000000..6467caaf6fd4
--- /dev/null
+++ b/news/py-sabyenc/pkg-descr
@@ -0,0 +1,11 @@
+Modified the original yenc module by Alessandro Duca alessandro.duca@gmail.com
+for use within SABnzbd.
+
+The module was extended to do header parsing and full yEnc decoding from a
+Python list of chunks, the way in which data is retrieved from usenet. This is
+particularly beneficial when SSL is enabled, which limits the size of each
+chunk to 16K. Parsing these chunks in Python is much more costly. Additionally,
+this module releases Python's GIL during decoding, greatly increasing
+performance of the overall download process.
+
+WWW: https://github.com/sabnzbd/sabyenc