aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-15 01:19:46 +0800
committermat <mat@FreeBSD.org>2015-12-15 01:19:46 +0800
commit1b3d2a3da0cdb98937d1aeef73120a96d7acce7c (patch)
tree8dbc64af4eddf9dd05b68e9c12c741aa8094226a /news
parentf2a2c753f8ad7d986e5ff2f7c2770ce66a94d81b (diff)
downloadfreebsd-ports-gnome-1b3d2a3da0cdb98937d1aeef73120a96d7acce7c.tar.gz
freebsd-ports-gnome-1b3d2a3da0cdb98937d1aeef73120a96d7acce7c.tar.zst
freebsd-ports-gnome-1b3d2a3da0cdb98937d1aeef73120a96d7acce7c.zip
Make build as a user.
While there, convert to autoreconf, options helpers, rename patches to match our naming scheme. Sponsored by: Absolight
Diffstat (limited to 'news')
-rw-r--r--news/nntpcache/Makefile39
-rw-r--r--news/nntpcache/files/patch-cf_Makefile.am16
-rw-r--r--news/nntpcache/files/patch-cf_Makefile.in21
-rw-r--r--news/nntpcache/files/patch-http_Makefile.am12
-rw-r--r--news/nntpcache/files/patch-http_Makefile.in17
-rw-r--r--news/nntpcache/files/patch-innreport_Makefile.am11
-rw-r--r--news/nntpcache/files/patch-innreport_Makefile.in17
-rw-r--r--news/nntpcache/files/patch-pgp_Makefile.am13
-rw-r--r--news/nntpcache/files/patch-pgp_Makefile.in15
-rw-r--r--news/nntpcache/files/patch-scripts-nntpcache-gdb.sh.in10
-rw-r--r--news/nntpcache/files/patch-scripts_nntpcache-gdb.sh.in10
-rw-r--r--news/nntpcache/files/patch-src_Makefile.am (renamed from news/nntpcache/files/patch-src_Makefile.in)8
-rw-r--r--news/nntpcache/files/patch-src_acc.c (renamed from news/nntpcache/files/patch-src-acc.c)8
-rw-r--r--news/nntpcache/files/patch-src_authinfo__ldap.c (renamed from news/nntpcache/files/patch-src-authinfo_ldap.c)6
-rw-r--r--news/nntpcache/files/patch-src_nntpcache.c (renamed from news/nntpcache/files/patch-src-nntpcache.c)6
-rw-r--r--news/nntpcache/files/patch-unixauth_Makefile.am12
-rw-r--r--news/nntpcache/files/patch-unixauth_Makefile.in15
-rw-r--r--news/nntpcache/pkg-plist44
18 files changed, 116 insertions, 164 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 8a8de4416a6e..e3cbfdc1df39 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -3,23 +3,24 @@
PORTNAME= nntpcache
PORTVERSION= 3.0.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= news
MASTER_SITES= http://www.xs4all.nl/~suelette/
MAINTAINER= leeym@FreeBSD.org
COMMENT= News caching/anti-spam/server-merging system
-USE_AUTOTOOLS= automake:env
-
# This may be set interactively at install-time. NNTPCache will
# cache news articles and related data in ${SPOOLDIR}/nntpcache.
SPOOLDIR?= /var/spool
NO_CDROM= Free for individuals and non-military, non-profit organisations only
-USES= gmake
+USES= gmake autoreconf shebangfix
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=${SPOOLDIR}
+CONFIGURE_ARGS= --localstatedir=${SPOOLDIR} \
+ --program-transform-name=''
+
+SHEBANG_FILES= contrib/perlnewshound/newshound.pl
AUTHINFO_EXT= authinfo_pam.ext
USE_RC_SUBR= nntpcached
@@ -27,34 +28,24 @@ USE_RC_SUBR= nntpcached
OPTIONS_DEFINE= LDAP RADIUS SPAMPHOBIA
SPAMPHOBIA_DESC= Spamphobia NoCeM support
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MRADIUS}
-CONFIGURE_ARGS+= --with-authinfo-radius
-AUTHINFO_EXT+= authinfo_radius.ext
-.endif
+RADIUS_CONFIGURE_WITH= authinfo-radius
+RADIUS_VARS= AUTHINFO_EXT+=authinfo_radius.ext
-.if ${PORT_OPTIONS:MLDAP} || defined(WITH_LDAP2)
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+= --with-authinfo-ldap
-CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
-LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib
-AUTHINFO_EXT+= authinfo_ldap.ext
-.endif
-CONFIGURE_ARGS+= --program-transform-name=''
+LDAP_USE= OPENLDAP=yes
+LDAP_CONFIGURE_WITH= authinfo-ldap
+LDAP_CPPFLAGS= -I${PREFIX}/include -I${LOCALBASE}/include
+LDAP_LDFLAGS= -L${PREFIX}/lib -L${LOCALBASE}/lib
+LDAP_VARS= AUTHINFO_EXT+=authinfo_ldap.ext
NNTPSPOOLDIR?= ${SPOOLDIR}/${PORTNAME}
PLIST_SUB+= SPOOLDIR=${NNTPSPOOLDIR}
CPIO_CMD= ${CPIO} --quiet -pdum -R
-MAN8= nntpcached.8 newshound.8
PORTDOCS= AUTHORS ChangeLog FAQ FAQ.html HACKING HTML \
INSTALL LICENSING NEWS README README.INN VERSION
-.if ${PORT_OPTIONS:MSPAMPHOBIA}
REVISEDATE= 20060903
-PATCH_SITES+= http://people.freebsd.org/~leeym/:SPAMPHOBIA
-PATCHFILES+= ${DISTNAME}-spamphobia-${REVISEDATE}.diff.gz:SPAMPHOBIA
-.endif
+SPAMPHOBIA_PATCH_SITES= http://people.freebsd.org/~leeym/:SPAMPHOBIA
+SPAMPHOBIA_PATCHFILES= ${DISTNAME}-spamphobia-${REVISEDATE}.diff.gz:SPAMPHOBIA
post-configure:
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} -C ${WRKSRC}/src ${AUTHINFO_EXT}
diff --git a/news/nntpcache/files/patch-cf_Makefile.am b/news/nntpcache/files/patch-cf_Makefile.am
new file mode 100644
index 000000000000..35ee282040ab
--- /dev/null
+++ b/news/nntpcache/files/patch-cf_Makefile.am
@@ -0,0 +1,16 @@
+--- cf/Makefile.am.orig 2004-04-11 11:43:52 UTC
++++ cf/Makefile.am
+@@ -22,13 +22,5 @@ VERSION:
+ echo @VERSION@ >$@
+
+
+-install-data-hook:
+- for f in $(distf); do { cd $(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
+-
+ nntpcache.config-dist : nnconf.cf
+ sed -e 's/^ *[a-zA-Z_][a-zA-Z_]* //;s/"//g' <nnconf.cf >$@
+-
+-# this is ugly, but more flexible than merely redefining INSTALL_DATA
+-install-data-local:
+- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
+- cd $(localstatedir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(localstate_DATA) && chown @nntpcacheUID@ $(localstate_DATA) && chgrp @nntpcacheGID@ $(localstate_DATA)
diff --git a/news/nntpcache/files/patch-cf_Makefile.in b/news/nntpcache/files/patch-cf_Makefile.in
deleted file mode 100644
index f218ba17ae60..000000000000
--- a/news/nntpcache/files/patch-cf_Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- cf/Makefile.in.orig 2006-03-05 16:49:25.000000000 -0500
-+++ cf/Makefile.in 2014-03-29 12:18:45.000000000 -0400
-@@ -271,15 +271,15 @@
- echo @VERSION@ >$@
-
- install-data-hook:
-- for f in $(distf); do { cd $(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
-+ for f in $(distf); do { cd $(DESTDIR)$(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
-
- nntpcache.config-dist : nnconf.cf
- sed -e 's/^ *[a-zA-Z_][a-zA-Z_]* //;s/"//g' <nnconf.cf >$@
-
- # this is ugly, but more flexible than merely redefining INSTALL_DATA
- install-data-local:
-- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
-- cd $(localstatedir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(localstate_DATA) && chown @nntpcacheUID@ $(localstate_DATA) && chgrp @nntpcacheGID@ $(localstate_DATA)
-+ cd $(DESTDIR)$(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
-+ cd $(DESTDIR)$(localstatedir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(localstate_DATA) && chown @nntpcacheUID@ $(localstate_DATA) && chgrp @nntpcacheGID@ $(localstate_DATA)
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/news/nntpcache/files/patch-http_Makefile.am b/news/nntpcache/files/patch-http_Makefile.am
new file mode 100644
index 000000000000..4f4793e6518e
--- /dev/null
+++ b/news/nntpcache/files/patch-http_Makefile.am
@@ -0,0 +1,12 @@
+--- http/Makefile.am.orig 2004-04-11 11:43:56 UTC
++++ http/Makefile.am
+@@ -12,7 +12,5 @@ EXTRA_DIST = \
+ ch = . $(httpdata)
+
+ install-data-local:
+- -mkdir $(sysconfdir)/http
+- cp $(httpdata) $(sysconfdir)/http
+- cd $(sysconfdir)/http && chown @nntpcacheUID@ $(ch)
+- cd $(sysconfdir)/http && chgrp @nntpcacheUID@ $(ch)
++ -mkdir $(DESTDIR)$(sysconfdir)/http
++ cp $(httpdata) $(DESTDIR)$(sysconfdir)/http
diff --git a/news/nntpcache/files/patch-http_Makefile.in b/news/nntpcache/files/patch-http_Makefile.in
deleted file mode 100644
index fe73bcffa60b..000000000000
--- a/news/nntpcache/files/patch-http_Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- http/Makefile.in.orig 2014-03-29 12:19:41.000000000 -0400
-+++ http/Makefile.in 2014-03-29 12:20:08.000000000 -0400
-@@ -216,10 +216,10 @@
-
-
- install-data-local:
-- -mkdir $(sysconfdir)/http
-- cp $(httpdata) $(sysconfdir)/http
-- cd $(sysconfdir)/http && chown @nntpcacheUID@ $(ch)
-- cd $(sysconfdir)/http && chgrp @nntpcacheUID@ $(ch)
-+ -mkdir $(DESTDIR)$(sysconfdir)/http
-+ cp $(httpdata) $(DESTDIR)$(sysconfdir)/http
-+ cd $(DESTDIR)$(sysconfdir)/http && chown @nntpcacheUID@ $(ch)
-+ cd $(DESTDIR)$(sysconfdir)/http && chgrp @nntpcacheUID@ $(ch)
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/news/nntpcache/files/patch-innreport_Makefile.am b/news/nntpcache/files/patch-innreport_Makefile.am
new file mode 100644
index 000000000000..2135400faacb
--- /dev/null
+++ b/news/nntpcache/files/patch-innreport_Makefile.am
@@ -0,0 +1,11 @@
+--- innreport/Makefile.am.orig 2004-04-11 11:43:57 UTC
++++ innreport/Makefile.am
+@@ -15,7 +15,4 @@ EXTRA_DIST = \
+
+ # the trailing slash is to force symlink transversal
+ install-data-local:
+- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
+- -mkdir $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
+- chown @nntpcacheUID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
+- chgrp @nntpcacheGID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
++ -mkdir $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
diff --git a/news/nntpcache/files/patch-innreport_Makefile.in b/news/nntpcache/files/patch-innreport_Makefile.in
deleted file mode 100644
index 3afc775d1fd2..000000000000
--- a/news/nntpcache/files/patch-innreport_Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- innreport/Makefile.in.orig 2014-03-29 12:22:45.000000000 -0400
-+++ innreport/Makefile.in 2014-03-29 12:23:58.000000000 -0400
-@@ -265,10 +265,10 @@
-
- # the trailing slash is to force symlink transversal
- install-data-local:
-- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
-- -mkdir $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
-- chown @nntpcacheUID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
-- chgrp @nntpcacheGID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
-+ cd $(DESTDIR)$(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
-+ -mkdir $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
-+ chown @nntpcacheUID@ $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
-+ chgrp @nntpcacheGID@ $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/news/nntpcache/files/patch-pgp_Makefile.am b/news/nntpcache/files/patch-pgp_Makefile.am
new file mode 100644
index 000000000000..e588bd443ac5
--- /dev/null
+++ b/news/nntpcache/files/patch-pgp_Makefile.am
@@ -0,0 +1,13 @@
+--- pgp/Makefile.am.orig 2004-04-11 11:43:57 UTC
++++ pgp/Makefile.am
+@@ -8,10 +8,3 @@ sysconf_DATA = \
+ EXTRA_DIST = \
+ $(sysconf_DATA)
+
+-# the trailing slash is to force symlink transversal
+-install-data-local:
+- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
+-
+-install-data-hook:
+- for f in $(sysconf_DATA); do { cd $(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
+-
diff --git a/news/nntpcache/files/patch-pgp_Makefile.in b/news/nntpcache/files/patch-pgp_Makefile.in
deleted file mode 100644
index abd80d603fbd..000000000000
--- a/news/nntpcache/files/patch-pgp_Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- pgp/Makefile.in.orig 2014-03-29 12:21:08.000000000 -0400
-+++ pgp/Makefile.in 2014-03-29 12:21:29.000000000 -0400
-@@ -236,10 +236,10 @@
-
- # the trailing slash is to force symlink transversal
- install-data-local:
-- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
-+ cd $(DESTDIR)$(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
-
- install-data-hook:
-- for f in $(sysconf_DATA); do { cd $(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
-+ for f in $(sysconf_DATA); do { cd $(DESTDIR)$(sysconfdir) && (orig=`basename $$f -dist`; test -e $$orig || cp $$f $$orig) ;} done
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/news/nntpcache/files/patch-scripts-nntpcache-gdb.sh.in b/news/nntpcache/files/patch-scripts-nntpcache-gdb.sh.in
deleted file mode 100644
index defa0756f117..000000000000
--- a/news/nntpcache/files/patch-scripts-nntpcache-gdb.sh.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- scripts/nntpcache-gdb.sh.in.orig Sat Nov 25 10:36:56 2006
-+++ scripts/nntpcache-gdb.sh.in Sat Nov 25 10:38:14 2006
-@@ -61,6 +61,7 @@
- break
- fi
- done
-+exit
-
- (
- echo === uname -a
diff --git a/news/nntpcache/files/patch-scripts_nntpcache-gdb.sh.in b/news/nntpcache/files/patch-scripts_nntpcache-gdb.sh.in
new file mode 100644
index 000000000000..a73620bfa334
--- /dev/null
+++ b/news/nntpcache/files/patch-scripts_nntpcache-gdb.sh.in
@@ -0,0 +1,10 @@
+--- scripts/nntpcache-gdb.sh.in.orig 2004-04-11 11:43:50 UTC
++++ scripts/nntpcache-gdb.sh.in
+@@ -61,6 +61,7 @@ for n in $libexec/nntpcached.debug $prog
+ break
+ fi
+ done
++exit
+
+ (
+ echo === uname -a
diff --git a/news/nntpcache/files/patch-src_Makefile.in b/news/nntpcache/files/patch-src_Makefile.am
index 4f890d74b376..cdc03c1b692f 100644
--- a/news/nntpcache/files/patch-src_Makefile.in
+++ b/news/nntpcache/files/patch-src_Makefile.am
@@ -1,7 +1,7 @@
---- src/Makefile.in.orig 2014-03-29 14:09:54.000000000 -0400
-+++ src/Makefile.in 2014-03-29 14:10:16.000000000 -0400
-@@ -454,7 +454,7 @@
-
+--- src/Makefile.am.orig 2006-03-05 21:42:38 UTC
++++ src/Makefile.am
+@@ -61,7 +61,7 @@ nntpcached_LDADD = \
+ ../libradius/libradius.a
install-exec-hook:
- cp nntpcached $(libexecdir)/nntpcached.debug && chmod a+x $(libexecdir)/nntpcached.debug
diff --git a/news/nntpcache/files/patch-src-acc.c b/news/nntpcache/files/patch-src_acc.c
index 9c381942b87f..dcdaa2b03833 100644
--- a/news/nntpcache/files/patch-src-acc.c
+++ b/news/nntpcache/files/patch-src_acc.c
@@ -1,6 +1,6 @@
---- src/acc.c.orig Sat Feb 19 12:16:21 2000
-+++ src/acc.c Tue Sep 13 23:00:32 2005
-@@ -147,6 +147,7 @@
+--- src/acc.c.orig 2004-04-11 11:43:55 UTC
++++ src/acc.c
+@@ -147,6 +147,7 @@ static struct filter_chain *filterReadCo
if (strEq(fli->name, fi))
{
fc->filter = fli->filter;
@@ -8,7 +8,7 @@
goto cont;
}
}
-@@ -195,7 +195,7 @@
+@@ -195,7 +196,7 @@ static struct filter_chain *filterReadCo
loge (("bad filter header/scope %s in file %s: %s", scope, fi, buf));
Exit(1);
}
diff --git a/news/nntpcache/files/patch-src-authinfo_ldap.c b/news/nntpcache/files/patch-src_authinfo__ldap.c
index 99b4a551cfd1..50f75a0805e4 100644
--- a/news/nntpcache/files/patch-src-authinfo_ldap.c
+++ b/news/nntpcache/files/patch-src_authinfo__ldap.c
@@ -1,6 +1,6 @@
---- src/authinfo_ldap.c.orig Sat Dec 18 12:08:30 1999
-+++ src/authinfo_ldap.c Wed Sep 26 10:55:27 2001
-@@ -78,7 +78,16 @@
+--- src/authinfo_ldap.c.orig 2004-04-11 11:43:55 UTC
++++ src/authinfo_ldap.c
+@@ -78,7 +78,16 @@ EXPORT int ldap_got_pass(char *pass)
lderr = ldap_bind_s(ld, dnbuf, pass, LDAP_AUTH_SIMPLE);
if (lderr != LDAP_SUCCESS && lderr != LDAP_INVALID_CREDENTIALS && lderr != LDAP_INAPPROPRIATE_AUTH)
diff --git a/news/nntpcache/files/patch-src-nntpcache.c b/news/nntpcache/files/patch-src_nntpcache.c
index ef3e490f551b..ed6cb03c42ab 100644
--- a/news/nntpcache/files/patch-src-nntpcache.c
+++ b/news/nntpcache/files/patch-src_nntpcache.c
@@ -1,6 +1,6 @@
---- src/nntpcache.c.orig Fri Mar 17 07:53:45 2006
-+++ src/nntpcache.c Fri Mar 17 07:53:51 2006
-@@ -810,7 +810,7 @@
+--- src/nntpcache.c.orig 2004-04-11 11:43:56 UTC
++++ src/nntpcache.c
+@@ -810,7 +810,7 @@ static bool load_servers(char *file)
loge (("missing password in %s:%d: %s", file, n, buf));
continue;
}
diff --git a/news/nntpcache/files/patch-unixauth_Makefile.am b/news/nntpcache/files/patch-unixauth_Makefile.am
new file mode 100644
index 000000000000..65b6155320de
--- /dev/null
+++ b/news/nntpcache/files/patch-unixauth_Makefile.am
@@ -0,0 +1,12 @@
+--- unixauth/Makefile.am.orig 2004-04-11 11:43:57 UTC
++++ unixauth/Makefile.am
+@@ -8,9 +8,4 @@ INCLUDES = \
+ -I../cf \
+ -I../common
+
+-install-exec-hook:
+- chown root $(libexecdir)/unixauth
+- chgrp @nntpcacheGID@ $(libexecdir)/unixauth
+- chmod u+s,g+x,o-x $(libexecdir)/unixauth
+-
+ include ../mk/rules.mk
diff --git a/news/nntpcache/files/patch-unixauth_Makefile.in b/news/nntpcache/files/patch-unixauth_Makefile.in
deleted file mode 100644
index 9d47abf4f8b2..000000000000
--- a/news/nntpcache/files/patch-unixauth_Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- unixauth/Makefile.in.orig 2014-03-29 12:25:30.000000000 -0400
-+++ unixauth/Makefile.in 2014-03-29 12:26:15.000000000 -0400
-@@ -327,9 +327,9 @@
-
-
- install-exec-hook:
-- chown root $(libexecdir)/unixauth
-- chgrp @nntpcacheGID@ $(libexecdir)/unixauth
-- chmod u+s,g+x,o-x $(libexecdir)/unixauth
-+ chown root $(DESTDIR)$(libexecdir)/unixauth
-+ chgrp @nntpcacheGID@ $(DESTDIR)$(libexecdir)/unixauth
-+ chmod u+s,g+x,o-x $(DESTDIR)$(libexecdir)/unixauth
-
- %.ext : %.c %.h $(top_srcdir)/config.h $(top_srcdir)/scripts/genextern.sh
- CPP="$(CPP)";export CPP; sh $(top_srcdir)/scripts/genextern.sh $< > $@.tmp $(DEFS) $(INCLUDES) $(CPPFLAGS) && mv -f $@.tmp $@ || rm -f $@.tmp
diff --git a/news/nntpcache/pkg-plist b/news/nntpcache/pkg-plist
index 1a55d1c0cd48..6553dae98b99 100644
--- a/news/nntpcache/pkg-plist
+++ b/news/nntpcache/pkg-plist
@@ -1,49 +1,31 @@
-@exec mkdir -p %%SPOOLDIR%%
bin/confused
bin/mmap_tests
-%%ETCDIR%%/VERSION
-@unexec rm %%SPOOLDIR%%/VERSION 2>&1 >/dev/null || true
-@exec cp %D/%F %%SPOOLDIR%%
-@exec chown -R news:news %%SPOOLDIR%%
-@exec chmod 750 %%SPOOLDIR%%
-@exec chmod 640 %%SPOOLDIR%%/VERSION
+@(news,news,600) %%ETCDIR%%/VERSION
%%ETCDIR%%/http/index.html
%%ETCDIR%%/http/moose.gif
%%ETCDIR%%/http/nntpcache.jpg
-%%ETCDIR%%/innreport.conf-dist
+@sample(,,600) %%ETCDIR%%/innreport.conf-dist %%ETCDIR%%/innreport.conf
%%ETCDIR%%/innreport.pl
%%ETCDIR%%/innreport.pm
-%%ETCDIR%%/newshound.conf-dist
-@unexec if cmp -s %D/%%ETCDIR%%/nntpcache.access %D/etc/nntpcache/nntpcache.access-dist; then rm -f %D/etc/nntpcache/nntpcache.access; fi
-%%ETCDIR%%/nntpcache.access-dist
-@exec if [ ! -f %D/%%ETCDIR%%/nttpcache.access ]; then cp -p %D/%F %B/nntpcache.access
-@unexec if cmp -s %D/%%ETCDIR%%/nntpcache.config %D/etc/nntpcache/nntpcache.config-dist; then rm -f %D/etc/nntpcache/nntpcache.config; fi
-%%ETCDIR%%/nntpcache.config-dist
-@exec if [ ! -f %D/%%ETCDIR%%/nttpcache.config ]; then cp -p %D/%F %B/nntpcache.config
-@unexec if cmp -s %D/%%ETCDIR%%/nntpcache.servers %D/etc/nntpcache/nntpcache.servers-dist; then rm -f %D/etc/nntpcache/nntpcache.servers; fi
-%%ETCDIR%%/nntpcache.servers-dist
-@exec if [ ! -f %D/%%ETCDIR%%/nttpcache.servers ]; then cp -p %D/%F %B/nntpcache.servers
-@unexec if cmp -s %D/%%ETCDIR%%/pubring.asc %D/etc/nntpcache/pubring.asc-dist; then rm -f %D/etc/nntpcache/pubring.asc; fi
-%%ETCDIR%%/pubring.asc-dist
-@exec if [ ! -f %D/%%ETCDIR%%/pubring.asc ]; then cp -p %D/%F %B/pubring.asc
-@unexec if cmp -s %D/%%ETCDIR%%/pubring.pgp %D/etc/nntpcache/pubring.pgp-dist; then rm -f %D/etc/nntpcache/pubring.pgp; fi
-%%ETCDIR%%/pubring.pgp-dist
-@exec if [ ! -f %D/%%ETCDIR%%/pubring.pgp ]; then cp -p %D/%F %B/pubring.pgp
+@sample(,,600) %%ETCDIR%%/newshound.conf-dist %%ETCDIR%%/newshound.conf
+@sample(,,600) %%ETCDIR%%/nntpcache.access-dist %%ETCDIR%%/nntpcache.access
+@sample(,,600) %%ETCDIR%%/nntpcache.config-dist %%ETCDIR%%/nntpcache.config
+@sample(,,600) %%ETCDIR%%/nntpcache.servers-dist %%ETCDIR%%/nntpcache.servers
+@sample(,,600) %%ETCDIR%%/pubring.asc-dist %%ETCDIR%%/pubring.asc
+@sample(,,600) %%ETCDIR%%/pubring.pgp-dist %%ETCDIR%%/pubring.pgp
%%ETCDIR%%/spam.filter
include/mmap_results.h
libexec/nntpcache-gdb.sh
libexec/nntpcache.gdb
libexec/nntpcached.debug
-libexec/unixauth
+@(root,news,4550) libexec/unixauth
man/man8/newshound.8.gz
man/man8/nntpcached.8.gz
sbin/innreport.sh
sbin/newshound
sbin/newshound.pl
sbin/nntpcached
-@exec mkdir -p %D/%%ETCDIR%%/http/innreport/pics
-@dirrm %%ETCDIR%%/http/innreport/pics
-@dirrm %%ETCDIR%%/http/innreport
-@dirrm %%ETCDIR%%/http
-@dirrmtry %%ETCDIR%%
-@unexec rmdir %%SPOOLDIR%% 2>&1 >/dev/null || echo "If you want to completely remove nntpcached, please execute 'rm -fr %%SPOOLDIR%%' by yourself."; true
+@(news,news,600) %%SPOOLDIR%%/VERSION
+@dir %%ETCDIR%%/http/innreport/pics
+@dir(news,news,700) %%ETCDIR%%
+@dir(news,news,770) %%SPOOLDIR%%