aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committertijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit67f12d415fec83113a7ddfbc9655db98b4e70a28 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /news
parent2088f53b95d04c86b1aece3d66aaca36ec5aaec2 (diff)
downloadfreebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.gz
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.zst
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'news')
-rw-r--r--news/newsstar/Makefile5
-rw-r--r--news/noffle/Makefile2
2 files changed, 3 insertions, 4 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index db2fa37eb3c1..16b53d8dcd4d 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -23,14 +23,13 @@ SHEBANG_FILES= newsstar.in
OPTIONS_DEFINE= SSL
OPTIONS_DEFAULT= SSL
-CONFIGURE_ARGS+=--prefix=${PREFIX} \
- --disable-chown \
+CONFIGURE_ARGS+=--disable-chown \
--with-conf-dir=${PREFIX}/etc/newsstar \
--with-rc-dir=/var/spool/newsstar/lib \
--with-incoming-dir=/var/spool/newsstar/incoming
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
.include <bsd.port.options.mk>
diff --git a/news/noffle/Makefile b/news/noffle/Makefile
index 82df632623da..275e33dd63de 100644
--- a/news/noffle/Makefile
+++ b/news/noffle/Makefile
@@ -16,8 +16,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-configfile=${LOCALBASE}/etc/noffle.conf \
--with-usersfile=${LOCALBASE}/etc/noffle.users
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
SPOOL_DIR= /var/spool/noffle
PLIST_SUB+= SPOOL_DIR=${SPOOL_DIR}