aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 19:36:08 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 19:36:08 +0800
commit7ce28ec46965feca6863995b32c8950e13474e83 (patch)
treea7df00c69d6994326f1e446b51ef07f4c2d5bd9d /news
parent8cec66239d1400f4613e78b6aee3df982692b5e8 (diff)
downloadfreebsd-ports-gnome-7ce28ec46965feca6863995b32c8950e13474e83.tar.gz
freebsd-ports-gnome-7ce28ec46965feca6863995b32c8950e13474e83.tar.zst
freebsd-ports-gnome-7ce28ec46965feca6863995b32c8950e13474e83.zip
Properly strip binaries and support cross building
Diffstat (limited to 'news')
-rw-r--r--news/sn/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/news/sn/Makefile b/news/sn/Makefile
index ab43637b2010..a190edfa24a5 100644
--- a/news/sn/Makefile
+++ b/news/sn/Makefile
@@ -21,13 +21,16 @@ PORTDOCS= README CHANGES FAQ INSTALL INTERNALS \
THANKS TODO INSTALL.notes INSTALL.notes2 \
INSTALL.run INSTALL.upgrade
+INSTALL_TARGET= strip install
+
OPTIONS_DEFINE= DOCS
# Try to fix parallel builds (-jX); respect CFLAGS
post-patch:
${REINPLACE_CMD} -e 's|sn\.a$$|& lib/libstuff.a| ; \
s|snlockf\.o$$|& lib/libstuff.a| ; \
- s|-g -Wall -pedantic -O|${CFLAGS} -Wall -pedantic|' \
+ s|-g -Wall -pedantic -O|${CFLAGS} -Wall -pedantic| ; \
+ s|strip |${STRIP_CMD} |' \
${WRKSRC}/Makefile
pre-install: