aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2007-01-17 21:38:12 +0800
committerleeym <leeym@FreeBSD.org>2007-01-17 21:38:12 +0800
commit83fd095c413ddb2cbe018e8fcd57795359416b24 (patch)
treecc12c4e2ab8cb275418632284f3f1c31797b8f82 /news
parent3af217ab6d5a6e606a684013337d1ae4ecea428b (diff)
downloadfreebsd-ports-gnome-83fd095c413ddb2cbe018e8fcd57795359416b24.tar.gz
freebsd-ports-gnome-83fd095c413ddb2cbe018e8fcd57795359416b24.tar.zst
freebsd-ports-gnome-83fd095c413ddb2cbe018e8fcd57795359416b24.zip
- fix a bug to handle duplicate spam.filter in nntpcache.access correctly.
(patch sent back to authors. fix it first before next release)
Diffstat (limited to 'news')
-rw-r--r--news/nntpcache/Makefile2
-rw-r--r--news/nntpcache/files/patch-src-acc.c8
2 files changed, 9 insertions, 1 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 9b8857921abf..ba59a1a1eba2 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nntpcache
PORTVERSION= 3.0.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= news
MASTER_SITES= http://www.nntpcache.com/pub/nntpcache/
diff --git a/news/nntpcache/files/patch-src-acc.c b/news/nntpcache/files/patch-src-acc.c
index f5de8a38b1e2..9c381942b87f 100644
--- a/news/nntpcache/files/patch-src-acc.c
+++ b/news/nntpcache/files/patch-src-acc.c
@@ -1,5 +1,13 @@
--- src/acc.c.orig Sat Feb 19 12:16:21 2000
+++ src/acc.c Tue Sep 13 23:00:32 2005
+@@ -147,6 +147,7 @@
+ if (strEq(fli->name, fi))
+ {
+ fc->filter = fli->filter;
++ fc->name = fli->name;
+ goto cont;
+ }
+ }
@@ -195,7 +195,7 @@
loge (("bad filter header/scope %s in file %s: %s", scope, fi, buf));
Exit(1);