aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-19 14:24:33 +0800
committermarino <marino@FreeBSD.org>2015-04-19 14:24:33 +0800
commitb1f73b2e928ddcbee4ab5a54912edc6915311b49 (patch)
treec8a83a158524afc5f3f4f1df603f34a0f5d38dc7 /news
parentc5e51233a433a99ce633ba3da544bbb157758499 (diff)
downloadfreebsd-ports-gnome-b1f73b2e928ddcbee4ab5a54912edc6915311b49.tar.gz
freebsd-ports-gnome-b1f73b2e928ddcbee4ab5a54912edc6915311b49.tar.zst
freebsd-ports-gnome-b1f73b2e928ddcbee4ab5a54912edc6915311b49.zip
news/husky-(fidoconf|htick|hpt) : builds INFO pages everywhere again
Jan Beich fixed the info pages (thanks Jan!) so this enables their building for htick and fidoconf of FreeBSD 11 and DragonFly. While here, commit USES+=makeinfo to -hpt that went uncommitted accidently yesterday.
Diffstat (limited to 'news')
-rw-r--r--news/husky-fidoconf/Makefile17
-rw-r--r--news/husky-hpt/Makefile1
-rw-r--r--news/husky-htick/Makefile8
3 files changed, 7 insertions, 19 deletions
diff --git a/news/husky-fidoconf/Makefile b/news/husky-fidoconf/Makefile
index 6d665fd4a105..09c99ebea3df 100644
--- a/news/husky-fidoconf/Makefile
+++ b/news/husky-fidoconf/Makefile
@@ -16,22 +16,15 @@ INSTALL_TARGET= install install-man
MASTERDIR= ${.CURDIR}/../husky
COMPONENT_SUBDIR= fidoconf
-post-patch:
- ${REINPLACE_CMD} -e 's^/path/to/config^${PREFIX}/etc/fido/config^' \
- ${WRKSRC}/man/linkedto.1
-
-# The texi files are too old for the ports texinfo
-# The correct fix is to update the texi file so modern texinfo can use it
-# Until then, disable installation of info page on FreeBSD 11 and DragonFly
-# to unbreak the build on those platforms.
-.if !exists(/usr/bin/makeinfo)
- ${REINPLACE_CMD} -e '/cd doc /d' ${WRKSRC}/Makefile
-.else
+# Settings below are required to handle texi output (html, INFO page)
USES+= makeinfo
PORTDOCS= fidoconfig.html
DOCSDIR= ${PREFIX}/share/doc/husky
INFO= fidoconfig
-.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's^/path/to/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/linkedto.1
post-install:
${LN} -sf fconf2.1 ${STAGEDIR}${PREFIX}/man/man1/fconf2aquaed.1
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
index 2945ed8acab7..c992677ea042 100644
--- a/news/husky-hpt/Makefile
+++ b/news/husky-hpt/Makefile
@@ -9,6 +9,7 @@ COMMENT= Husky FTN tosser
LIB_DEPENDS= libfidoconfig.so:${PORTSDIR}/news/husky-fidoconf \
libareafix.so:${PORTSDIR}/news/husky-areafix
+USES+= makeinfo
ALL_TARGET= all doc
INSTALL_TARGET= install install-doc
INFO= hpt
diff --git a/news/husky-htick/Makefile b/news/husky-htick/Makefile
index 9eee49cf2699..452ed7441492 100644
--- a/news/husky-htick/Makefile
+++ b/news/husky-htick/Makefile
@@ -17,19 +17,13 @@ PLIST_FILES= bin/htick man/man1/htick.1.gz
MASTERDIR= ${.CURDIR}/../husky
COMPONENT_SUBDIR= htick
-# The texi files are too old for the ports texinfo
-# The correct fix is to update the texi file so modern texinfo can use it
-# Until then, disable installation of info page on FreeBSD 11 and DragonFly
-# to unbreak the build on those platforms.
-.if !exists(/usr/bin/makeinfo)
-.else
+# Settings below are required to handle texi output (html, INFO page)
USES+= makeinfo
ALL_TARGET+= doc
INSTALL_TARGET+= install-doc
PORTDOCS= htick.html
DOCSDIR= ${PREFIX}/share/doc/husky
INFO= htick
-.endif
post-patch:
${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \