aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2002-06-05 22:06:39 +0800
committercy <cy@FreeBSD.org>2002-06-05 22:06:39 +0800
commitd1c175e1559f73ed59fd0575028b858b18ca9ae1 (patch)
tree77211241184c501160fa8771adcf42278d4a7331 /news
parentc8696d92990056d1bce4846bd08620c214873dbc (diff)
downloadfreebsd-ports-gnome-d1c175e1559f73ed59fd0575028b858b18ca9ae1.tar.gz
freebsd-ports-gnome-d1c175e1559f73ed59fd0575028b858b18ca9ae1.tar.zst
freebsd-ports-gnome-d1c175e1559f73ed59fd0575028b858b18ca9ae1.zip
Fix a format string vulnerability.
Obtained from: SRT Security Advisory (SRT2002-06-04-1011): slurp, posted to BUGTRAQ on June 4, 2002, by zillion <zillion@snosoft.com>.
Diffstat (limited to 'news')
-rw-r--r--news/slurp/Makefile1
-rw-r--r--news/slurp/files/patch-misc.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/news/slurp/Makefile b/news/slurp/Makefile
index 4b6956cbdcf5..c432aefe1c31 100644
--- a/news/slurp/Makefile
+++ b/news/slurp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= slurp
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ftp://ftp.demon.co.uk/pub/news/slurp/
EXTRACT_SUFX= .tar.Z
diff --git a/news/slurp/files/patch-misc.c b/news/slurp/files/patch-misc.c
new file mode 100644
index 000000000000..bb4de48e9238
--- /dev/null
+++ b/news/slurp/files/patch-misc.c
@@ -0,0 +1,11 @@
+--- misc.c.orig Tue Feb 7 06:32:01 1995
++++ misc.c Wed Jun 5 06:12:43 2002
+@@ -108,7 +108,7 @@
+ (void) strcat (buf, "\n");
+ #ifdef SYSLOG
+ if (!debug_flag)
+- syslog (LOG_ERR, buf);
++ syslog (LOG_ERR, "%s", buf);
+ else
+ #endif
+ (void) fprintf (stderr, "%s: %s", pname, buf);