aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-07-09 16:16:40 +0800
committerclement <clement@FreeBSD.org>2004-07-09 16:16:40 +0800
commited6366a7afd46a4ddeb63fbe8883458de93aa35d (patch)
tree75bde86fc383f95cdebfd410ffb7b4e12b22b48d /news
parent2299f917f33e2bb9d0fb66be6c6b507a8dcca229 (diff)
downloadfreebsd-ports-gnome-ed6366a7afd46a4ddeb63fbe8883458de93aa35d.tar.gz
freebsd-ports-gnome-ed6366a7afd46a4ddeb63fbe8883458de93aa35d.tar.zst
freebsd-ports-gnome-ed6366a7afd46a4ddeb63fbe8883458de93aa35d.zip
- Update to 20040707 snapshot
- Make db42 the default berkeleydb version - preserves news/db directory
Diffstat (limited to 'news')
-rw-r--r--news/inn-stable/Makefile13
-rw-r--r--news/inn-stable/distinfo4
-rw-r--r--news/inn-stable/files/patch-configure44
-rw-r--r--news/inn-stable/files/patch-site:Makefile (renamed from news/inn-stable/files/patch-site::Makefile)18
-rw-r--r--news/inn-stable/pkg-plist8
5 files changed, 59 insertions, 28 deletions
diff --git a/news/inn-stable/Makefile b/news/inn-stable/Makefile
index 2e77afef01bc..b6c9801fe142 100644
--- a/news/inn-stable/Makefile
+++ b/news/inn-stable/Makefile
@@ -7,7 +7,6 @@
PORTNAME= inn
PORTVERSION= ${SNAPSHOT}
-PORTREVISION= 1
CATEGORIES= news ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=clement
@@ -18,7 +17,7 @@ MAINTAINER= clement@FreeBSD.org
COMMENT= InterNetNews -- the Internet meets Netnews
BRANCH= stable
-SNAPSHOT= 20040118
+SNAPSHOT= 20040707
NO_LATEST_LINK= yes
USE_GMAKE= yes
@@ -51,17 +50,19 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
.if defined(WITH_BERKELEYDB)
CONFIGURE_ARGS+= --with-berkeleydb=${LOCABASE}
. if !defined(WITH_BDB_VER)
-WITH_BDB_VER= 41
+WITH_BDB_VER= 42
. endif
. if (${WITH_BDB_VER} == 3) || (${WITH_BDB_VER} == 4) || (${WITH_BDB_VER} == 41)
LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
+.elif (${WITH_BDB_VER} == 42)
+LIB_DEPENDS+= db-4.2:${PORTSDIR}/databases/db42
. elif ${WITH_BDB_VER} == 2
-BROKEN= "Does not compile with db2"
+IGNORE= "Does not compile with db2"
. else
-BROKEN= "Unknown BerkeleyDB version"
+IGNORE= "Unknown BerkeleyDB version"
. endif
CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
-CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
+CONFIGURE_ARGS+= --with-berkeleydb
.endif
.if defined(WITH_PYTHON)
diff --git a/news/inn-stable/distinfo b/news/inn-stable/distinfo
index 25a8e68de05e..c8504db4742a 100644
--- a/news/inn-stable/distinfo
+++ b/news/inn-stable/distinfo
@@ -1,2 +1,2 @@
-MD5 (inn-STABLE-20040118.tar.gz) = ba62a140b25670602957f20d2f5d23e9
-SIZE (inn-STABLE-20040118.tar.gz) = 1851913
+MD5 (inn-STABLE-20040707.tar.gz) = 72644e9c1fa6f4f7834896813ab8691d
+SIZE (inn-STABLE-20040707.tar.gz) = 1852037
diff --git a/news/inn-stable/files/patch-configure b/news/inn-stable/files/patch-configure
index efc64a5cee58..ff34b2727ae3 100644
--- a/news/inn-stable/files/patch-configure
+++ b/news/inn-stable/files/patch-configure
@@ -1,11 +1,25 @@
---- configure.orig Tue Sep 2 06:39:30 2003
-+++ configure Wed Oct 22 15:23:46 2003
-@@ -5826,36 +5826,9 @@
- done
- done
- fi
+--- configure.orig Mon Jun 14 16:49:57 2004
++++ configure Fri Jul 9 07:47:06 2004
+@@ -5811,49 +5811,18 @@
+ BERKELEY_DB_LIB=
+ else
+ echo "$ac_t""yes" 1>&6
+- echo $ac_n "checking for BerkeleyDB location""... $ac_c" 1>&6
++ echo $ac_n "checking for BerkeleyDB ${DB_VER} location""... $ac_c" 1>&6
+ echo "configure:5816: checking for BerkeleyDB location" >&5
- if test x"$BERKELEY_DB_DIR" = xyes ; then
-- for v in db41 db4 db3 db2 ; do
+- for v in BerkeleyDB BerkeleyDB.3.0 BerkeleyDB.3.1 BerkeleyDB.3.2 \
+- BerkeleyDB.3.3 BerkeleyDB.4.0 BerkeleyDB.4.1 BerkeleyDB.4.2 ; do
+- for d in $prefix /usr/local /opt /usr ; do
+- if test -d "$d/$v" ; then
+- BERKELEY_DB_DIR="$d/$v"
+- break
+- fi
+- done
+- done
+- fi
+- if test x"$BERKELEY_DB_DIR" = xyes ; then
+- for v in db42 db41 db4 db3 db2 ; do
- if test -d "/usr/local/include/$v" ; then
- BERKELEY_DB_LDFLAGS="-L/usr/local/lib"
- BERKELEY_DB_CFLAGS="-I/usr/local/include/$v"
@@ -15,7 +29,7 @@
- fi
- done
- if test x"$BERKELEY_DB_LIB" = x ; then
-- for v in db41 db4 db3 db2 ; do
+- for v in db42 db41 db4 db3 db2 ; do
- if test -d "/usr/include/$v" ; then
- BERKELEY_DB_CFLAGS="-I/usr/include/$v"
- BERKELEY_DB_LIB="-l$v"
@@ -29,13 +43,21 @@
- fi
- fi
- else
- BERKELEY_DB_LDFLAGS="-L$BERKELEY_DB_DIR/lib"
+- BERKELEY_DB_LDFLAGS="-L$BERKELEY_DB_DIR/lib"
- BERKELEY_DB_CFLAGS="-I$BERKELEY_DB_DIR/include"
- BERKELEY_DB_LIB="-ldb"
- echo "$ac_t""$BERKELEY_DB_DIR" 1>&6
- fi
-+ BERKELEY_DB_CFLAGS="-I$BERKELEY_DB_DIR/include/${DB_VER}"
-+ BERKELEY_DB_LIB="-l${DB_VER}"
++ BERKELEY_DB_DIR="${LOCALBASE}"
++ BERKELEY_DB_LDFLAGS="-L${LOCALBASE}/lib"
++ BERKELEY_DB_CFLAGS="-I${LOCALBASE}/include/${DB_VER}"
++ if [ "${DB_VER}" != "db42" ]
++ then
++ BERKELEY_DB_LIB="-l${DB_VER}"
++ else
++ BERKELEY_DB_LIB="-ldb-4.2"
++ fi
++ echo "$ac_t""$BERKELEY_DB_DIR" 1>&6
cat >> confdefs.h <<\EOF
#define USE_BERKELEY_DB 1
EOF
diff --git a/news/inn-stable/files/patch-site::Makefile b/news/inn-stable/files/patch-site:Makefile
index 5a22a277e000..8eb8c467a406 100644
--- a/news/inn-stable/files/patch-site::Makefile
+++ b/news/inn-stable/files/patch-site:Makefile
@@ -1,5 +1,5 @@
---- site/Makefile.orig Sat Jul 12 21:11:02 2003
-+++ site/Makefile Sun Sep 21 12:53:00 2003
+--- site/Makefile.orig Wed May 26 04:02:32 2004
++++ site/Makefile Fri Jul 9 07:56:05 2004
@@ -23,29 +23,29 @@
PATH_NNRPAUTH = ${PATHFILTER}/nnrpd_auth.pl
PATH_NNRPYAUTH = ${PATHFILTER}/nnrpd_auth.py
@@ -53,7 +53,7 @@
PATH_ACTIVE = ${PATHDB}/active
PATH_ACTIVE_TIMES = ${PATHDB}/active.times
-@@ -71,8 +71,8 @@
+@@ -72,8 +72,8 @@
$D$(PATH_NEWSFEEDS) $D$(PATH_INNDHOSTS) \
$D$(PATH_NNRPDTRACK) $D$(PATH_NNTPPASS) \
$D$(PATH_CONFIG) $D$(PATH_MODERATORS) \
@@ -64,7 +64,7 @@
$D$(PATH_CTLWATCH) $D$(PATH_DISTPATS) $D$(PATH_SCHEMA) \
$D$(PATH_ACTSYNC_CFG) $D$(PATH_ACTSYNC_IGN) \
$D$(PATH_MOTD) $D$(PATH_STORAGECONF) \
-@@ -81,7 +81,7 @@
+@@ -82,14 +82,14 @@
$D$(PATH_PERL_FILTER_INND) $D$(PATH_PERL_FILTER_NNRPD) \
$D$(PATH_PYTHON_FILTER_INND) $D$(PATH_PYTHON_INN_MODULE) \
$D$(PATH_TCL_STARTUP) $D$(PATH_TCL_FILTER) \
@@ -73,7 +73,15 @@
$D$(PATH_RADIUS_CONF) $D$(PATH_NNRPYAUTH) $D$(PATH_OVDB_CONF) \
$D$(PATH_SASL_CONF) $D$(PATH_SUBSCRIPTIONS)
-@@ -170,9 +170,9 @@
+ ALL_INSTALLED = $(MOST_INSTALLED) $(REST_INSTALLED)
+
+ SPECIAL = $D$(PATH_ACTIVE) $D$(PATH_ACTIVE_TIMES) \
+- $D$(PATH_NEWSGROUPS) $D$(PATH_HISTORY)
++ $D$(PATH_NEWSGROUPS)
+
+ ## Get new versions of everything from samples directory.
+ all: $(P) $(ALL) config
+@@ -175,9 +175,9 @@
$D$(PATH_MODERATORS): moderators ; $(COPY_RPUB) $? $@
$D$(PATH_DISTPATS): distrib.pats ; $(COPY_RPUB) $? $@
$D$(PATH_NNTPPASS): passwd.nntp ; $(COPY_RPRI) $? $@
diff --git a/news/inn-stable/pkg-plist b/news/inn-stable/pkg-plist
index 286132507013..c0e5eeac4caf 100644
--- a/news/inn-stable/pkg-plist
+++ b/news/inn-stable/pkg-plist
@@ -100,10 +100,10 @@ news/bin/startinnfeed
news/bin/tally.control
news/bin/tdx-util
news/bin/writelog
-news/db/active
-news/db/active.times
-news/db/history
-news/db/history.dir
+@comment news/db/active
+@comment news/db/active.times
+@comment news/db/history
+@comment news/db/history.dir
%%SUB_WITHOUT_TAGGED_HASH%%news/db/history.hash
%%SUB_WITHOUT_TAGGED_HASH%%news/db/history.index
%%SUB_WITH_TAGGED_HASH%%news/db/history.pag