aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-12-25 20:21:17 +0800
committersf <sf@FreeBSD.org>2001-12-25 20:21:17 +0800
commit15396de27ca99fd3a8fd5268985623cd0ad22f75 (patch)
tree4daf5ec35b5245990feb69185a77867dbeea384a /news
parent1126e428e6791c5614a3173eacf903409dc1e710 (diff)
downloadfreebsd-ports-gnome-15396de27ca99fd3a8fd5268985623cd0ad22f75.tar.gz
freebsd-ports-gnome-15396de27ca99fd3a8fd5268985623cd0ad22f75.tar.zst
freebsd-ports-gnome-15396de27ca99fd3a8fd5268985623cd0ad22f75.zip
o fix build: catch false condition.
o portlint. PR: 33167(build error)
Diffstat (limited to 'news')
-rw-r--r--news/tin/Makefile12
-rw-r--r--news/tin/pkg-plist1
2 files changed, 7 insertions, 6 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index eb440916e408..9f104a9dfc0d 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -58,13 +58,15 @@ pre-configure:
${CP} ${FILESDIR}/pcre.h ${WRKSRC}/pcre
post-configure:
- (nm /usr/lib/libc.a | grep -q strcasestr) && \
- echo "#define HAVE_STRCASESTR 1" >> ${WRKSRC}/include/autoconf.h
- echo "#define HAVE_ICONV_H 1" >> ${WRKSRC}/include/autoconf.h
- echo "#define HAVE_ICONV 1" >> ${WRKSRC}/include/autoconf.h
+ if nm /usr/lib/libc.a | ${GREP} -q strcasestr; then \
+ ${ECHO} "#define HAVE_STRCASESTR 1" \
+ >> ${WRKSRC}/include/autoconf.h; \
+ fi
+ ${ECHO} "#define HAVE_ICONV_H 1" >> ${WRKSRC}/include/autoconf.h
+ ${ECHO} "#define HAVE_ICONV 1" >> ${WRKSRC}/include/autoconf.h
post-build:
- cd ${WRKSRC}/po; gmake
+ cd ${WRKSRC}/po; ${GMAKE}
post-install:
cd ${WRKSRC}/doc; ${INSTALL_DATA} tin.defaults ${PREFIX}/etc/tin.defaults.dist
diff --git a/news/tin/pkg-plist b/news/tin/pkg-plist
index 72ad1e19373b..00a5c2ede1fe 100644
--- a/news/tin/pkg-plist
+++ b/news/tin/pkg-plist
@@ -10,4 +10,3 @@ etc/tin.mime.types.dist
share/locale/de/LC_MESSAGES/tin.mo
share/locale/en_GB/LC_MESSAGES/tin.mo
share/locale/et/LC_MESSAGES/tin.mo
-