aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-12-13 07:37:57 +0800
committerkwm <kwm@FreeBSD.org>2015-12-13 07:37:57 +0800
commitb3ff1d773d2cf151da5cc108bbc32cda8784c524 (patch)
tree0d2aa5e6ce9997008d0a83fe0551135734d1651c /news
parent65c7a59fb62534a1d8c4fc221aa689918253170a (diff)
downloadfreebsd-ports-gnome-b3ff1d773d2cf151da5cc108bbc32cda8784c524.tar.gz
freebsd-ports-gnome-b3ff1d773d2cf151da5cc108bbc32cda8784c524.tar.zst
freebsd-ports-gnome-b3ff1d773d2cf151da5cc108bbc32cda8784c524.zip
Staticly link to libgcc and libstdc++. This fixes a segmentation fault
when trying to run pan on a libc++ based system. PR: 199303 Submitted by: Andrew <andrew_terekhov@yahoo.com>
Diffstat (limited to 'news')
-rw-r--r--news/pan/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index d740f17abf43..15fa3eeb849a 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pan
PORTVERSION= 0.139
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
@@ -22,7 +22,8 @@ USE_GNOME= intlhack
USE_GCC= any
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex ${ICONV_LIB}
+LDFLAGS+= -static-libgcc -static-libstdc++ -L${LOCALBASE}/lib \
+ -lgnuregex ${ICONV_LIB}
OPTIONS_DEFINE= GTKSPELL GTK3
OPTIONS_DEFAULT=GTKSPELL