aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-08-25 13:33:11 +0800
committernovel <novel@FreeBSD.org>2006-08-25 13:33:11 +0800
commitc3571a59b330966314ff82ef12ed87cfc1681c7d (patch)
tree46bb5100e8d716ae6f47e6a10f85cabd0587c20c /news
parentc99313ae745acb806c74d09c1a92cbe7d7ff7e31 (diff)
downloadfreebsd-ports-gnome-c3571a59b330966314ff82ef12ed87cfc1681c7d.tar.gz
freebsd-ports-gnome-c3571a59b330966314ff82ef12ed87cfc1681c7d.tar.zst
freebsd-ports-gnome-c3571a59b330966314ff82ef12ed87cfc1681c7d.zip
This a fairly simple Python module, it provides only raw yEnc
encoding/decoding with built-in crc32 calculation. PR: ports/102497 Submitted by: Alexander Botero-Lowry <alex at foxybanana.com>
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/py-yenc/Makefile20
-rw-r--r--news/py-yenc/distinfo3
-rw-r--r--news/py-yenc/pkg-descr2
-rw-r--r--news/py-yenc/pkg-plist4
5 files changed, 30 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index ec073f9428ba..964512a3b7fa 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -80,6 +80,7 @@
SUBDIR += pgpmoose
SUBDIR += plor
SUBDIR += py-twistedNews
+ SUBDIR += py-yenc
SUBDIR += pyne
SUBDIR += rawdog
SUBDIR += rkive
diff --git a/news/py-yenc/Makefile b/news/py-yenc/Makefile
new file mode 100644
index 000000000000..7bae100b5831
--- /dev/null
+++ b/news/py-yenc/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-yenc
+# Date created: 24 Aug 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yenc
+PORTVERSION= 0.3
+CATEGORIES= news python
+MASTER_SITES= http://www.hellanzb.com/hellanzb-content/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A yenc decoding module for Python in C
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/news/py-yenc/distinfo b/news/py-yenc/distinfo
new file mode 100644
index 000000000000..bbc82288e0fd
--- /dev/null
+++ b/news/py-yenc/distinfo
@@ -0,0 +1,3 @@
+MD5 (yenc-0.3.tar.gz) = 7b3edd32db6c1ce566ad550e3de64c83
+SHA256 (yenc-0.3.tar.gz) = fb04fea7c5821345608fa01728ce5356b6dfb2d3e469e59e3fd31b88f45fb313
+SIZE (yenc-0.3.tar.gz) = 42740
diff --git a/news/py-yenc/pkg-descr b/news/py-yenc/pkg-descr
new file mode 100644
index 000000000000..576122d476e5
--- /dev/null
+++ b/news/py-yenc/pkg-descr
@@ -0,0 +1,2 @@
+This a fairly simple Python module, it provides only raw yEnc
+encoding/decoding with built-in crc32 calculation.
diff --git a/news/py-yenc/pkg-plist b/news/py-yenc/pkg-plist
new file mode 100644
index 000000000000..94a5dc3e7bf5
--- /dev/null
+++ b/news/py-yenc/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/_yenc.so
+%%PYTHON_SITELIBDIR%%/yenc.py
+%%PYTHON_SITELIBDIR%%/yenc.pyc
+%%PYTHON_SITELIBDIR%%/yenc.pyo