aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-04 10:24:29 +0800
committeredwin <edwin@FreeBSD.org>2007-10-04 10:24:29 +0800
commit27bcde2bbeb9705ab9909fa624324d2dabc8a3c3 (patch)
tree9732a636b574b55c7fbddc861c58994a5b2bb9d5 /news
parent390824965052cc70180f9260020ce05f7bac73b3 (diff)
downloadfreebsd-ports-gnome-27bcde2bbeb9705ab9909fa624324d2dabc8a3c3.tar.gz
freebsd-ports-gnome-27bcde2bbeb9705ab9909fa624324d2dabc8a3c3.tar.zst
freebsd-ports-gnome-27bcde2bbeb9705ab9909fa624324d2dabc8a3c3.zip
Remove always-false/true conditions based on OSVERSION 500000
Diffstat (limited to 'news')
-rw-r--r--news/fidogate/Makefile10
-rw-r--r--news/hellanzb/Makefile8
2 files changed, 5 insertions, 13 deletions
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index 9ee1a6cbf372..a83afe5b6f1d 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -16,6 +16,8 @@ MASTER_SITE_SUBDIR= system/fido
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Fido-Internet Gateway and Tosser
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-perl
+
.if !defined(WITHOUT_IFCICO)
RUN_DEPENDS= ${LOCALBASE}/libexec/ifmail/ifcico:${PORTSDIR}/news/ifmail
.endif
@@ -30,12 +32,6 @@ DOCLIST= fidogate.texi fidogate.txt gatebau94.txt kludge-rfc.doc \
MAKE_ENV+= CC=${CC}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-perl
-.endif
-
pre-configure:
${TOUCH} ${WRKSRC}/doc/fidogate.info
${RM} -f ${WRKSRC}/doc/fidogate.info-?
@@ -62,4 +58,4 @@ post-install:
@${TAR} -C ${WRKSRC}/examples -cf - . | ${TAR} -C ${EXAMPLESDIR} -xf -
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/news/hellanzb/Makefile b/news/hellanzb/Makefile
index 94ad260d7044..b358194789c2 100644
--- a/news/hellanzb/Makefile
+++ b/news/hellanzb/Makefile
@@ -20,18 +20,14 @@ RUN_DEPENDS= par2:${PORTSDIR}/archivers/par2cmdline \
shorten:${PORTSDIR}/audio/shorten \
${PYTHON_SITELIBDIR}/yenc.py:${PORTSDIR}/news/py-yenc \
${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore \
- ${PYTHON_SITELIBDIR}/twisted/web:${PORTSDIR}/www/py-twistedWeb
+ ${PYTHON_SITELIBDIR}/twisted/web:${PORTSDIR}/www/py-twistedWeb \
+ mac:${PORTSDIR}/audio/mac
USE_PYTHON= yes
USE_PYDISTUTILS=yes
.include <bsd.port.pre.mk>
-# monkey audio (mac) needs FreeBSD 5
-.if ${OSVERSION} >= 500000
-RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
-.endif
-
# more fully-featured rar needs at least 5.3
.if ${ARCH} == "i386" && ${OSVERSION} >= 503000
RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar