aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-06-18 01:25:23 +0800
committerolgeni <olgeni@FreeBSD.org>2001-06-18 01:25:23 +0800
commit50637dc0440505b3ef780e1b26be5a7567e2c874 (patch)
tree529ae442986fa814e1760b1d7740b7657cc99633 /news
parent88bb820b994e842dcdba10e68211591efb157fe8 (diff)
downloadfreebsd-ports-gnome-50637dc0440505b3ef780e1b26be5a7567e2c874.tar.gz
freebsd-ports-gnome-50637dc0440505b3ef780e1b26be5a7567e2c874.tar.zst
freebsd-ports-gnome-50637dc0440505b3ef780e1b26be5a7567e2c874.zip
Preserve files in etc/. Change pkg-install to avoid overwriting them at
install time.
Diffstat (limited to 'news')
-rw-r--r--news/nn/pkg-install12
-rw-r--r--news/nn/pkg-plist8
2 files changed, 14 insertions, 6 deletions
diff --git a/news/nn/pkg-install b/news/nn/pkg-install
index 49cbe7dd84ab..f796ec9c3cf5 100644
--- a/news/nn/pkg-install
+++ b/news/nn/pkg-install
@@ -28,8 +28,7 @@ cat << xxENDxx
*******************************************************************
xxENDxx
-if [ ! -f ${PKG_PREFIX}/etc/nntp_server ]; then
- cat << xxENDxx > ${PKG_PREFIX}/etc/nntp_server
+cat << xxENDxx > ${PKG_PREFIX}/etc/nntp_server.dist
# nntp_server: Configuration file for NN newsreader
#
# Set your NNTP server address or hostname in this file.
@@ -39,10 +38,12 @@ if [ ! -f ${PKG_PREFIX}/etc/nntp_server ]; then
#
# news.myisp.com
xxENDxx
+
+if [ ! -e ${PKG_PREFIX}/etc/nntp_server ]; then
+ cp ${PKG_PREFIX}/etc/nntp_server.dist ${PKG_PREFIX}/etc/nntp_server
fi
-if [ ! -f ${PKG_PREFIX}/etc/nntp_domain ]; then
- cat << xxENDxx > ${PKG_PREFIX}/etc/nntp_domain
+cat << xxENDxx > ${PKG_PREFIX}/etc/nntp_domain.dist
# nntp_domain: Configuration file for NN newsreader
#
# Set the default domain name portion of user e-mail addresses as you
@@ -57,4 +58,7 @@ if [ ! -f ${PKG_PREFIX}/etc/nntp_domain ]; then
# If this file is left blank, NN will use the hostname of this
# computer as the From: domain name.
xxENDxx
+
+if [ ! -e ${PKG_PREFIX}/etc/nntp_domain ]; then
+ cp ${PKG_PREFIX}/etc/nntp_domain.dist ${PKG_PREFIX}/etc/nntp_domain
fi
diff --git a/news/nn/pkg-plist b/news/nn/pkg-plist
index 382283022e1a..dcff0687e2af 100644
--- a/news/nn/pkg-plist
+++ b/news/nn/pkg-plist
@@ -11,8 +11,12 @@ bin/nntidy
bin/nnusage
bin/nnview
bin/nn-inews
-etc/nntp_domain
-etc/nntp_server
+@unexec if cmp -s %D/etc/nntp_domain %D/etc/nntp_domain.dist; then rm -f %D/etc/nntp_domain; fi
+etc/nntp_domain.dist
+@exec [ -f %B/nntp_domain ] || cp %B/%f %B/nntp_domain
+@unexec if cmp -s %D/etc/nntp_server %D/etc/nntp_server.dist; then rm -f %D/etc/nntp_server; fi
+etc/nntp_server.dist
+@exec [ -f %B/nntp_server ] || cp %B/%f %B/nntp_server
lib/nn/aux
lib/nn/conf
lib/nn/help/Manual